p PatchFirst

CVE-2016-4658

CVE-2016-4658

This page contains facts from public vulnerability sources. Check the original advisory before updating.

xpointer.c in libxml2 before 2.9.5 (as used in Apple iOS before 10, OS X before 10.12, tvOS before 10, and watchOS before 3, and other products) does not forbid namespace nodes in XPointer ranges, which allows remote attackers to execute arbitrary code or cause a denial of service (use-after-free and memory corruption) via a crafted XML document.

CVSS 9.8 · Critical · EPSS 8.6% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • libxml2 Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.9.4+dfsg1-2.1

    Update to 2.9.4+dfsg1-2.1

  • libxml2 Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.9.4+dfsg1-2.1

    Update to 2.9.4+dfsg1-2.1

  • libxml2 Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.9.4+dfsg1-2.1

    Update to 2.9.4+dfsg1-2.1

  • libxml2 Ubuntu:14.04:LTS

    Versions
    • 2.9.1+dfsg1-3ubuntu2
    • 2.9.1+dfsg1-3ubuntu3
    • 2.9.1+dfsg1-3ubuntu4
    • 2.9.1+dfsg1-3ubuntu4.1
    • 2.9.1+dfsg1-3ubuntu4.2
    • 2.9.1+dfsg1-3ubuntu4.3
    • 2.9.1+dfsg1-3ubuntu4.4
    • 2.9.1+dfsg1-3ubuntu4.5
    • 2.9.1+dfsg1-3ubuntu4.6
    • 2.9.1+dfsg1-3ubuntu4.7
    • 2.9.1+dfsg1-3ubuntu4.8
    Affected ranges
    • ECOSYSTEM: < 2.9.1+dfsg1-3ubuntu4.9

    Update to 2.9.1+dfsg1-3ubuntu4.9

  • libxml2 Ubuntu:16.04:LTS

    Versions
    • 2.9.2+zdfsg1-4
    • 2.9.2+zdfsg1-4ubuntu1
    • 2.9.2+zdfsg1-4ubuntu2
    • 2.9.2+zdfsg1-4ubuntu3
    • 2.9.3+dfsg1-1
    • 2.9.3+dfsg1-1ubuntu0.1
    Affected ranges
    • ECOSYSTEM: < 2.9.3+dfsg1-1ubuntu0.2

    Update to 2.9.3+dfsg1-1ubuntu0.2

Original sources

Check your server →