CVE-2016-5131
CVE-2016-5131
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This page shows selected source facts. See the linked advisories for the complete description and affected versions.
Use-after-free vulnerability in libxml2 through 2.9.4, as used in Google Chrome before 52.0.2743.82, allows remote attackers to cause a denial of service or possibly have unspecified other impact via vectors related to the XPointer range-to function.
CVSS 8.8 · High · EPSS 2.3% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
libxml2 Debian:12
- Affected ranges
- ECOSYSTEM: < 2.9.4+dfsg1-2.1
Update to 2.9.4+dfsg1-2.1
libxml2 Debian:13
- Affected ranges
- ECOSYSTEM: < 2.9.4+dfsg1-2.1
Update to 2.9.4+dfsg1-2.1
libxml2 Debian:14
- Affected ranges
- ECOSYSTEM: < 2.9.4+dfsg1-2.1
Update to 2.9.4+dfsg1-2.1
chromium-browser Ubuntu:14.04:LTS
- Versions
- 29.0.1547.65-0ubuntu2
- 31.0.1650.63-0ubuntu1~20131204.1
- 32.0.1700.107-0ubuntu1~20140204.977.1
- 33.0.1750.152-0ubuntu1~pkg995.1
- 34.0.1847.116-0ubuntu2
- 36.0.1985.125-0ubuntu1.14.04.0~pkg1029
- 37.0.2062.94-0ubuntu0.14.04.1~pkg1042
- 37.0.2062.120-0ubuntu0.14.04.1~pkg1049
- 38.0.2125.111-0ubuntu0.14.04.1.1061
- 39.0.2171.65-0ubuntu0.14.04.1.1064
- 40.0.2214.94-0ubuntu0.14.04.1.1068
- 40.0.2214.111-0ubuntu0.14.04.1.1069
- 41.0.2272.76-0ubuntu0.14.04.1.1076
- 43.0.2357.81-0ubuntu0.14.04.1.1089
- 43.0.2357.130-0ubuntu0.14.04.1.1092
- 44.0.2403.89-0ubuntu0.14.04.1.1095
- 45.0.2454.85-0ubuntu0.14.04.1.1097
- 45.0.2454.101-0ubuntu0.14.04.1.1099
- 47.0.2526.73-0ubuntu0.14.04.1.1106
- 47.0.2526.106-0ubuntu0.14.04.1.1107
- 48.0.2564.82-0ubuntu0.14.04.1.1108
- 48.0.2564.116-0ubuntu0.14.04.1.1111
- 49.0.2623.87-0ubuntu0.14.04.1.1112
- 49.0.2623.108-0ubuntu0.14.04.1.1113
- 50.0.2661.102-0ubuntu0.14.04.1.1117
- 51.0.2704.79-0ubuntu0.14.04.1.1121
- Affected ranges
- ECOSYSTEM: < 52.0.2743.116-0ubuntu0.14.04.1.1134
Update to 52.0.2743.116-0ubuntu0.14.04.1.1134
libxml2 Ubuntu:14.04:LTS
- Versions
- 2.9.1+dfsg1-3ubuntu2
- 2.9.1+dfsg1-3ubuntu3
- 2.9.1+dfsg1-3ubuntu4
- 2.9.1+dfsg1-3ubuntu4.1
- 2.9.1+dfsg1-3ubuntu4.2
- 2.9.1+dfsg1-3ubuntu4.3
- 2.9.1+dfsg1-3ubuntu4.4
- 2.9.1+dfsg1-3ubuntu4.5
- 2.9.1+dfsg1-3ubuntu4.6
- 2.9.1+dfsg1-3ubuntu4.7
- 2.9.1+dfsg1-3ubuntu4.8
- Affected ranges
- ECOSYSTEM: < 2.9.1+dfsg1-3ubuntu4.9
Update to 2.9.1+dfsg1-3ubuntu4.9
oxide-qt Ubuntu:14.04:LTS
- Versions
- 1.0.0~bzr437-0ubuntu1
- 1.0.0~bzr452-0ubuntu1
- 1.0.0~bzr475-0ubuntu1
- 1.0.0~bzr490-0ubuntu1
- 1.0.0~bzr501-0ubuntu1
- 1.0.0~bzr501-0ubuntu2
- 1.0.4-0ubuntu0.14.04.1
- 1.0.5-0ubuntu0.14.04.1
- 1.1.2-0ubuntu0.14.04.1
- 1.2.5-0ubuntu0.14.04.1
- 1.3.4-0ubuntu0.14.04.1
- 1.4.2-0ubuntu0.14.04.1
- 1.4.3-0ubuntu0.14.04.1
- 1.5.5-0ubuntu0.14.04.3
- 1.5.6-0ubuntu0.14.04.2
- 1.6.5-0ubuntu0.14.04.1
- 1.6.6-0ubuntu0.14.04.1
- 1.7.8-0ubuntu0.14.04.1
- 1.7.9-0ubuntu0.14.04.1
- 1.8.4-0ubuntu0.14.04.2
- 1.9.1-0ubuntu0.14.04.2
- 1.9.5-0ubuntu0.14.04.1
- 1.10.3-0ubuntu0.14.04.1
- 1.11.3-0ubuntu0.14.04.1
- 1.11.4-0ubuntu0.14.04.1
- 1.12.5-0ubuntu0.14.04.1
- 1.12.6-0ubuntu0.14.04.1
- 1.12.7-0ubuntu0.14.04.1
- 1.13.6-0ubuntu0.14.04.1
- 1.14.7-0ubuntu0.14.04.1
- 1.14.9-0ubuntu0.14.04.1
- 1.15.7-0ubuntu0.14.04.1
- 1.15.8-0ubuntu0.14.04.1
- Affected ranges
- ECOSYSTEM: < 1.16.5-0ubuntu0.14.04.1
Update to 1.16.5-0ubuntu0.14.04.1
chromium-browser Ubuntu:16.04:LTS
- Versions
- 45.0.2454.101-0ubuntu1.1201
- 47.0.2526.73-0ubuntu1.1218
- 47.0.2526.106-0ubuntu1.1221
- 48.0.2564.82-0ubuntu1.1222
- 48.0.2564.116-0ubuntu1.1229
- 49.0.2623.87-0ubuntu1.1232
- 49.0.2623.108-0ubuntu1.1233
- 50.0.2661.102-0ubuntu0.16.04.1.1237
- 51.0.2704.79-0ubuntu0.16.04.1.1242
- Affected ranges
- ECOSYSTEM: < 52.0.2743.116-0ubuntu0.16.04.1.1250
Update to 52.0.2743.116-0ubuntu0.16.04.1.1250
libxml2 Ubuntu:16.04:LTS
- Versions
- 2.9.2+zdfsg1-4
- 2.9.2+zdfsg1-4ubuntu1
- 2.9.2+zdfsg1-4ubuntu2
- 2.9.2+zdfsg1-4ubuntu3
- 2.9.3+dfsg1-1
- 2.9.3+dfsg1-1ubuntu0.1
- Affected ranges
- ECOSYSTEM: < 2.9.3+dfsg1-1ubuntu0.2
Update to 2.9.3+dfsg1-1ubuntu0.2
oxide-qt Ubuntu:16.04:LTS
- Versions
- 1.9.5-0ubuntu1
- 1.10.3-0ubuntu0.15.10.1
- 1.10.3-0ubuntu0.15.10.2
- 1.11.3-0ubuntu3
- 1.11.4-0ubuntu1
- 1.11.5-0ubuntu1
- 1.12.5-0ubuntu1
- 1.12.6-0ubuntu1
- 1.12.7-0ubuntu1
- 1.13.6-0ubuntu1
- 1.14.7-0ubuntu1
- 1.14.9-0ubuntu0.16.04.1
- 1.15.7-0ubuntu0.16.04.1
- 1.15.8-0ubuntu0.16.04.1
- Affected ranges
- ECOSYSTEM: < 1.16.5-0ubuntu0.16.04.1
Update to 1.16.5-0ubuntu0.16.04.1
Original sources
- https://bugzilla.redhat.com/show_bug.cgi?id=1358641
- https://support.apple.com/HT207141
- https://crbug.com/623378
- http://lists.opensuse.org/opensuse-security-announce/2016-07/msg00021.html
- http://lists.opensuse.org/opensuse-security-announce/2016-07/msg00022.html
- http://lists.apple.com/archives/security-announce/2016/Sep/msg00006.html
- http://lists.apple.com/archives/security-announce/2016/Sep/msg00008.html
- http://www.securityfocus.com/bid/92053
- http://googlechromereleases.blogspot.com/2016/07/stable-channel-update.html
- http://lists.apple.com/archives/security-announce/2016/Sep/msg00010.html
- http://www.ubuntu.com/usn/USN-3041-1
- http://lists.opensuse.org/opensuse-security-announce/2016-07/msg00028.html
- https://source.android.com/security/bulletin/2017-05-01
- https://codereview.chromium.org/2127493002
- http://lists.apple.com/archives/security-announce/2016/Sep/msg00011.html
- https://support.apple.com/HT207170
- https://security.gentoo.org/glsa/201610-09
- https://security.gentoo.org/glsa/201701-37
- http://lists.opensuse.org/opensuse-security-announce/2016-07/msg00020.html
- https://support.apple.com/HT207142
- https://support.apple.com/HT207143
- http://rhn.redhat.com/errata/RHSA-2016-1485.html
- http://www.securitytracker.com/id/1038623
- https://nvd.nist.gov/vuln/detail/CVE-2016-5131