CVE-2016-5423
CVE-2016-5423
This page contains facts from public vulnerability sources. Check the original advisory before updating.
PostgreSQL before 9.1.23, 9.2.x before 9.2.18, 9.3.x before 9.3.14, 9.4.x before 9.4.9, and 9.5.x before 9.5.4 allow remote authenticated users to cause a denial of service (NULL pointer dereference and server crash), obtain sensitive memory information, or possibly execute arbitrary code via (1) a CASE expression within the test value subexpression of another CASE or (2) inlining of an SQL function that implements the equality operator used for a CASE expression involving values of different types.
CVSS 8.3 · High · EPSS 6.0% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
postgresql-9.1 Ubuntu:14.04:LTS
- Versions
- 9.1.10-1
- 9.1.10-1bzr1
- 9.1.11-1
- 9.1.11-2
- 9.1.12-1
- 9.1.13-1
- 9.1.14-0ubuntu0.14.04
- 9.1.15-0ubuntu0.14.04
- 9.1.16-0ubuntu0.14.04
- 9.1.17-0ubuntu0.14.04
- 9.1.18-0ubuntu0.14.04
- 9.1.19-0ubuntu0.14.04
- 9.1.20-0ubuntu0.14.04
- 9.1.21-0ubuntu0.14.04
- 9.1.22-0ubuntu0.14.04
- Affected ranges
- ECOSYSTEM: < 9.1.23-0ubuntu0.14.04
Update to 9.1.23-0ubuntu0.14.04
postgresql-9.3 Ubuntu:14.04:LTS
- Versions
- 9.3.1-1
- 9.3.2-1
- 9.3.2-1ubuntu1
- 9.3.2-1ubuntu2
- 9.3.3-1
- 9.3.3-1bzr1
- 9.3.3-1bzr2
- 9.3.4-1
- 9.3.5-0ubuntu0.14.04.1
- 9.3.6-0ubuntu0.14.04
- 9.3.7-0ubuntu0.14.04
- 9.3.8-0ubuntu0.4.04
- 9.3.9-0ubuntu0.14.04
- 9.3.10-0ubuntu0.14.04
- 9.3.11-0ubuntu0.14.04
- 9.3.12-0ubuntu0.14.04
- 9.3.13-0ubuntu0.14.04
- Affected ranges
- ECOSYSTEM: < 9.3.14-0ubuntu0.14.04
Update to 9.3.14-0ubuntu0.14.04
postgresql-9.5 Ubuntu:16.04:LTS
- Versions
- 9.5.0-1
- 9.5.0-2
- 9.5.0-3
- 9.5.1-1
- 9.5.2-1
- 9.5.3-0ubuntu0.16.04
- Affected ranges
- ECOSYSTEM: < 9.5.4-0ubuntu0.16.04
Update to 9.5.4-0ubuntu0.16.04
Original sources
- http://rhn.redhat.com/errata/RHSA-2016-1781.html
- https://www.postgresql.org/docs/current/static/release-9-4-9.html
- http://www.securitytracker.com/id/1036617
- http://rhn.redhat.com/errata/RHSA-2016-1821.html
- http://www.debian.org/security/2016/dsa-3646
- http://www.securityfocus.com/bid/92433
- https://security.gentoo.org/glsa/201701-33
- https://access.redhat.com/errata/RHSA-2017:2425
- https://www.postgresql.org/docs/current/static/release-9-5-4.html
- https://www.postgresql.org/docs/current/static/release-9-3-14.html
- https://www.postgresql.org/about/news/1688/
- https://www.postgresql.org/docs/current/static/release-9-2-18.html
- http://rhn.redhat.com/errata/RHSA-2016-2606.html
- http://rhn.redhat.com/errata/RHSA-2016-1820.html
- https://www.postgresql.org/docs/current/static/release-9-1-23.html
- https://bugzilla.redhat.com/show_bug.cgi?id=1364001
- https://nvd.nist.gov/vuln/detail/CVE-2016-5423