p PatchFirst

CVE-2016-5424

CVE-2016-5424

This page contains facts from public vulnerability sources. Check the original advisory before updating.

PostgreSQL before 9.1.23, 9.2.x before 9.2.18, 9.3.x before 9.3.14, 9.4.x before 9.4.9, and 9.5.x before 9.5.4 might allow remote authenticated users with the CREATEDB or CREATEROLE role to gain superuser privileges via a (1) " (double quote), (2) \ (backslash), (3) carriage return, or (4) newline character in a (a) database or (b) role name that is mishandled during an administrative operation.

CVSS 7.1 · High · EPSS 4.6% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • postgresql-9.1 Ubuntu:14.04:LTS

    Versions
    • 9.1.10-1
    • 9.1.10-1bzr1
    • 9.1.11-1
    • 9.1.11-2
    • 9.1.12-1
    • 9.1.13-1
    • 9.1.14-0ubuntu0.14.04
    • 9.1.15-0ubuntu0.14.04
    • 9.1.16-0ubuntu0.14.04
    • 9.1.17-0ubuntu0.14.04
    • 9.1.18-0ubuntu0.14.04
    • 9.1.19-0ubuntu0.14.04
    • 9.1.20-0ubuntu0.14.04
    • 9.1.21-0ubuntu0.14.04
    • 9.1.22-0ubuntu0.14.04
    Affected ranges
    • ECOSYSTEM: < 9.1.23-0ubuntu0.14.04

    Update to 9.1.23-0ubuntu0.14.04

  • postgresql-9.3 Ubuntu:14.04:LTS

    Versions
    • 9.3.1-1
    • 9.3.2-1
    • 9.3.2-1ubuntu1
    • 9.3.2-1ubuntu2
    • 9.3.3-1
    • 9.3.3-1bzr1
    • 9.3.3-1bzr2
    • 9.3.4-1
    • 9.3.5-0ubuntu0.14.04.1
    • 9.3.6-0ubuntu0.14.04
    • 9.3.7-0ubuntu0.14.04
    • 9.3.8-0ubuntu0.4.04
    • 9.3.9-0ubuntu0.14.04
    • 9.3.10-0ubuntu0.14.04
    • 9.3.11-0ubuntu0.14.04
    • 9.3.12-0ubuntu0.14.04
    • 9.3.13-0ubuntu0.14.04
    Affected ranges
    • ECOSYSTEM: < 9.3.14-0ubuntu0.14.04

    Update to 9.3.14-0ubuntu0.14.04

  • postgresql-9.5 Ubuntu:16.04:LTS

    Versions
    • 9.5.0-1
    • 9.5.0-2
    • 9.5.0-3
    • 9.5.1-1
    • 9.5.2-1
    • 9.5.3-0ubuntu0.16.04
    Affected ranges
    • ECOSYSTEM: < 9.5.4-0ubuntu0.16.04

    Update to 9.5.4-0ubuntu0.16.04

Original sources

Check your server →