p PatchFirst

CVE-2016-6855

CVE-2016-6855

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Eye of GNOME (aka eog) 3.16.5, 3.17.x, 3.18.x before 3.18.3, 3.19.x, and 3.20.x before 3.20.4, when used with glib before 2.44.1, allow remote attackers to cause a denial of service (out-of-bounds write and crash) via vectors involving passing invalid UTF-8 to GMarkup.

CVSS 7.5 · High · EPSS 18.4% · Public exploit · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • eog Debian:12

    Affected ranges
    • ECOSYSTEM: < 3.20.4-1

    Update to 3.20.4-1

  • eog Debian:13

    Affected ranges
    • ECOSYSTEM: < 3.20.4-1

    Update to 3.20.4-1

  • eog Debian:14

    Affected ranges
    • ECOSYSTEM: < 3.20.4-1

    Update to 3.20.4-1

  • eog Ubuntu:14.04:LTS

    Versions
    • 3.8.2-1ubuntu1
    • 3.10.1-1ubuntu1
    • 3.10.2-0ubuntu1
    • 3.10.2-0ubuntu2
    • 3.10.2-0ubuntu3
    • 3.10.2-0ubuntu4
    • 3.10.2-0ubuntu5
    • 3.10.2-0ubuntu5.1
    Affected ranges
    • ECOSYSTEM: < 3.10.2-0ubuntu5.2

    Update to 3.10.2-0ubuntu5.2

  • eog Ubuntu:16.04:LTS

    Versions
    • 3.16.3-1ubuntu2
    • 3.18.0-0ubuntu1
    • 3.18.0-1ubuntu1
    • 3.18.0-1ubuntu2
    • 3.18.1-1ubuntu1
    • 3.18.1-1ubuntu2
    • 3.18.2-1
    • 3.18.2-1ubuntu1
    • 3.18.2-1ubuntu2
    Affected ranges
    • ECOSYSTEM: < 3.18.2-1ubuntu2.1

    Update to 3.18.2-1ubuntu2.1

Original sources

Check your server →