p PatchFirst

PatchFirst · Latest vulnerabilities

eog vulnerabilities

Vulnerabilities published for eog in the last 30 days: 2. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 5

  1. CVE-2026-118475

    Low · CVSS 3.6EPSS 0.11%No fix published

    Eog: eye of gnome: buffer overrun when parsing malicious png files with non-standard iccp chunk

    A flaw was found in Eye of GNOME. When parsing a specially crafted PNG image containing malformed color profile metadata, the application fails to validate chunk boundaries while searching for a null terminator. An attacker could trick a user into opening a malicious image, causing the application to read past the allocated buffer. This issue can lead to an application crash, resulting in a Denial of Service (DoS), or potentially expose sensitive memory contents.

    Published Updated
  2. CVE-2026-107651

    Medium · CVSS 5.5EPSS 0.18%No fix published

    Eog: eog: arbitrary code execution via heap buffer overflow in png metadata reader

    A flaw was found in Eye of GNOME (eog). A heap-based buffer overflow exists in the PNG metadata reader due to improper state handling when parsing split metadata chunks. A remote attacker could exploit this flaw by enticing a user into opening a specially crafted PNG file, potentially leading to arbitrary code execution or a Denial of Service (DoS) via application crash.

    Published Updated
  3. CVE-2016-6855

    High · CVSS 7.5EPSS 18.38%Public exploitFix available

    CVE-2016-6855

    Eye of GNOME (aka eog) 3.16.5, 3.17.x, 3.18.x before 3.18.3, 3.19.x, and 3.20.x before 3.20.4, when used with glib before 2.44.1, allow remote attackers to cause a denial of service (out-of-bounds write and crash) via vectors involving passing invalid UTF-8 to GMarkup.

    • Update to 3.20.4-1
    Published Updated
  4. CVE-2008-5987

    Not ratedEPSS 0.4%Fix available

    CVE-2008-5987

    Untrusted search path vulnerability in the Python interface in Eye of GNOME (eog) 2.22.3, and possibly other versions, allows local users to execute arbitrary code via a Trojan horse Python file in the current working directory, related to a vulnerability in the PySys_SetArgv function (CVE-2008-5983).

    • Update to 2.22.3-2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →