p PatchFirst

CVE-2016-8621

CVE-2016-8621

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The `curl_getdate` function in curl before version 7.51.0 is vulnerable to an out of bounds read if it receives an input with one digit short.

CVSS 5.3 · Medium · EPSS 4.8% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • curl

    Versions
    • 7.51.0: Affected

    No fix published

  • curl Debian:12

    Affected ranges
    • ECOSYSTEM: < 7.51.0-1

    Update to 7.51.0-1

  • curl Debian:13

    Affected ranges
    • ECOSYSTEM: < 7.51.0-1

    Update to 7.51.0-1

  • curl Debian:14

    Affected ranges
    • ECOSYSTEM: < 7.51.0-1

    Update to 7.51.0-1

  • curl Ubuntu:14.04:LTS

    Versions
    • 7.32.0-1ubuntu1
    • 7.33.0-1ubuntu1
    • 7.34.0-1ubuntu1
    • 7.35.0-1ubuntu1
    • 7.35.0-1ubuntu2
    • 7.35.0-1ubuntu2.1
    • 7.35.0-1ubuntu2.2
    • 7.35.0-1ubuntu2.3
    • 7.35.0-1ubuntu2.5
    • 7.35.0-1ubuntu2.6
    • 7.35.0-1ubuntu2.7
    • 7.35.0-1ubuntu2.8
    • 7.35.0-1ubuntu2.9
    Affected ranges
    • ECOSYSTEM: < 7.35.0-1ubuntu2.10

    Update to 7.35.0-1ubuntu2.10

  • curl Ubuntu:16.04:LTS

    Versions
    • 7.43.0-1ubuntu2
    • 7.45.0-1ubuntu1
    • 7.46.0-1ubuntu1
    • 7.47.0-1ubuntu1
    • 7.47.0-1ubuntu2
    • 7.47.0-1ubuntu2.1
    Affected ranges
    • ECOSYSTEM: < 7.47.0-1ubuntu2.2

    Update to 7.47.0-1ubuntu2.2

Original sources

Check your server →