p PatchFirst

PatchFirst · Latest vulnerabilities

curl vulnerabilities

Vulnerabilities published for curl in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 43

  1. CVE-2021-22876

    Medium · CVSS 5.3EPSS 5.3%Fix available

    CVE-2021-22876

    curl 7.1.1 to and including 7.75.0 is vulnerable to an "Exposure of Private Personal Information to an Unauthorized Actor" by leaking credentials in the HTTP Referer: header. libcurl does not strip off user credentials from the URL when automatically populating the Referer: HTTP request header field in outgoing HTTP requests, and therefore risks leaking sensitive data to the server that is the target of the second HTTP request.

    • Update to 7.47.0-1ubuntu2.19
    Published Updated
  2. CVE-2020-8284

    Low · CVSS 3.7EPSS 3.9%Fix available

    CVE-2020-8284

    A malicious server can use the FTP PASV response to trick curl 7.73.0 and earlier into connecting back to a given IP address and port, and this way potentially make curl extract information about services that are otherwise private and not disclosed, for example doing port scanning and service banner extractions.

    • Update to 7.47.0-1ubuntu2.18
    Published Updated
  3. CVE-2019-3823

    Medium · CVSS 4.3EPSS 4.12%Fix available

    CVE-2019-3823

    libcurl versions from 7.34.0 to before 7.64.0 are vulnerable to a heap out-of-bounds read in the code handling the end-of-response for SMTP. If the buffer passed to `smtp_endofresp()` isn't NUL terminated and contains no character ending the parsed number, and `len` is set to 5, then the `strtol()` call reads beyond the allocated buffer. The read contents will not be returned to the caller.

    • Update to 7.47.0-1ubuntu2.12
    Published Updated
  4. CVE-2019-3822

    High · CVSS 7.1EPSS 12.87%Fix available

    CVE-2019-3822

    libcurl versions from 7.36.0 to before 7.64.0 are vulnerable to a stack-based buffer overflow. The function creating an outgoing NTLM type-3 header (`lib/vauth/ntlm.c:Curl_auth_create_ntlm_type3_message()`), generates the request HTTP header contents based on previously received data. The check that exists to prevent the local buffer from getting overflowed is implemented wrongly (using unsigned math) and as such it does not prevent the overflow from happening. This output data can grow larger than the local buffer if very large 'nt response' data is extracted from a previous NTLMv2 header provided by the malicious or broken HTTP server. Such

    • Update to 7.47.0-1ubuntu2.12
    Published Updated
  5. CVE-2018-16890

    Medium · CVSS 5.4EPSS 5.35%Fix available

    CVE-2018-16890

    libcurl versions from 7.36.0 to before 7.64.0 is vulnerable to a heap buffer out-of-bounds read. The function handling incoming NTLM type-2 messages (`lib/vauth/ntlm.c:ntlm_decode_type2_target`) does not validate incoming data correctly and is subject to an integer overflow vulnerability. Using that overflow, a malicious or broken NTLM server could trick libcurl to accept a bad length + offset combination that would lead to a buffer read out-of-bounds.

    • Update to 7.47.0-1ubuntu2.12
    Published Updated
  6. CVE-2018-14618

    High · CVSS 7.5EPSS 11.12%Fix available

    CVE-2018-14618

    curl before version 7.61.1 is vulnerable to a buffer overrun in the NTLM authentication code. The internal function Curl_ntlm_core_mk_nt_hash multiplies the length of the password by two (SUM) to figure out how large temporary storage area to allocate from the heap. The length value is then subsequently used to iterate over the password and generate output into the allocated storage buffer. On systems with a 32 bit size_t, the math to calculate SUM triggers an integer overflow when the password length exceeds 2GB (2^31 bytes). This integer overflow usually causes a very small buffer to actually get allocated instead of the intended very huge

    • Update to 7.47.0-1ubuntu2.9
    Published Updated
  7. CVE-2016-8616

    Low · CVSS 3.7EPSS 3.47%Fix available

    CVE-2016-8616

    A flaw was found in curl before version 7.51.0 When re-using a connection, curl was doing case insensitive comparisons of user name and password with the existing connections. This means that if an unused connection with proper credentials exists for a protocol that has connection-scoped credentials, an attacker can cause that connection to be reused if s/he knows the case-insensitive version of the correct password.

    • Update to 7.47.0-1ubuntu2.2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →