p PatchFirst

CVE-2016-9318

CVE-2016-9318

This page contains facts from public vulnerability sources. Check the original advisory before updating.

libxml2 2.9.4 and earlier, as used in XMLSec 1.2.23 and earlier and other products, does not offer a flag directly indicating that the current document may be read but other files may not be opened, which makes it easier for remote attackers to conduct XML External Entity (XXE) attacks via a crafted document.

CVSS 5.5 · Medium · EPSS 2.9% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • libxml2 Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.9.10+dfsg-2

    Update to 2.9.10+dfsg-2

  • libxml2 Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.9.10+dfsg-2

    Update to 2.9.10+dfsg-2

  • libxml2 Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.9.10+dfsg-2

    Update to 2.9.10+dfsg-2

  • libxml2 Ubuntu:14.04:LTS

    Versions
    • 2.9.1+dfsg1-3ubuntu2
    • 2.9.1+dfsg1-3ubuntu3
    • 2.9.1+dfsg1-3ubuntu4
    • 2.9.1+dfsg1-3ubuntu4.1
    • 2.9.1+dfsg1-3ubuntu4.2
    • 2.9.1+dfsg1-3ubuntu4.3
    • 2.9.1+dfsg1-3ubuntu4.4
    • 2.9.1+dfsg1-3ubuntu4.5
    • 2.9.1+dfsg1-3ubuntu4.6
    • 2.9.1+dfsg1-3ubuntu4.7
    • 2.9.1+dfsg1-3ubuntu4.8
    • 2.9.1+dfsg1-3ubuntu4.9
    • 2.9.1+dfsg1-3ubuntu4.10
    • 2.9.1+dfsg1-3ubuntu4.11
    • 2.9.1+dfsg1-3ubuntu4.12
    Affected ranges
    • ECOSYSTEM: < 2.9.1+dfsg1-3ubuntu4.13

    Update to 2.9.1+dfsg1-3ubuntu4.13

  • libxml2 Ubuntu:16.04:LTS

    Versions
    • 2.9.2+zdfsg1-4
    • 2.9.2+zdfsg1-4ubuntu1
    • 2.9.2+zdfsg1-4ubuntu2
    • 2.9.2+zdfsg1-4ubuntu3
    • 2.9.3+dfsg1-1
    • 2.9.3+dfsg1-1ubuntu0.1
    • 2.9.3+dfsg1-1ubuntu0.2
    • 2.9.3+dfsg1-1ubuntu0.3
    • 2.9.3+dfsg1-1ubuntu0.4
    • 2.9.3+dfsg1-1ubuntu0.5
    Affected ranges
    • ECOSYSTEM: < 2.9.3+dfsg1-1ubuntu0.6

    Update to 2.9.3+dfsg1-1ubuntu0.6

  • libxml2 Ubuntu:18.04:LTS

    Versions
    • 2.9.4+dfsg1-4ubuntu1
    • 2.9.4+dfsg1-5ubuntu1
    • 2.9.4+dfsg1-5ubuntu2
    • 2.9.4+dfsg1-5.1ubuntu1
    • 2.9.4+dfsg1-5.2ubuntu1
    • 2.9.4+dfsg1-6.1ubuntu1
    Affected ranges
    • ECOSYSTEM: < 2.9.4+dfsg1-6.1ubuntu1.2

    Update to 2.9.4+dfsg1-6.1ubuntu1.2

Original sources

Check your server →