p PatchFirst

CVE-2016-9586

CVE-2016-9586

This page contains facts from public vulnerability sources. Check the original advisory before updating.

curl before version 7.52.0 is vulnerable to a buffer overflow when doing a large floating point output in libcurl's implementation of the printf() functions. If there are any application that accepts a format string from the outside without necessary input filtering, it could allow remote attacks.

CVSS 5.9 · Medium · EPSS 4.7% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • curl

    Versions
    • curl 7.52.0: Affected

    No fix published

  • curl Debian:12

    Affected ranges
    • ECOSYSTEM: < 7.52.1-1

    Update to 7.52.1-1

  • curl Debian:13

    Affected ranges
    • ECOSYSTEM: < 7.52.1-1

    Update to 7.52.1-1

  • curl Debian:14

    Affected ranges
    • ECOSYSTEM: < 7.52.1-1

    Update to 7.52.1-1

  • curl Ubuntu:14.04:LTS

    Versions
    • 7.32.0-1ubuntu1
    • 7.33.0-1ubuntu1
    • 7.34.0-1ubuntu1
    • 7.35.0-1ubuntu1
    • 7.35.0-1ubuntu2
    • 7.35.0-1ubuntu2.1
    • 7.35.0-1ubuntu2.2
    • 7.35.0-1ubuntu2.3
    • 7.35.0-1ubuntu2.5
    • 7.35.0-1ubuntu2.6
    • 7.35.0-1ubuntu2.7
    • 7.35.0-1ubuntu2.8
    • 7.35.0-1ubuntu2.9
    • 7.35.0-1ubuntu2.10
    Affected ranges
    • ECOSYSTEM: < 7.35.0-1ubuntu2.11

    Update to 7.35.0-1ubuntu2.11

  • curl Ubuntu:16.04:LTS

    Versions
    • 7.43.0-1ubuntu2
    • 7.45.0-1ubuntu1
    • 7.46.0-1ubuntu1
    • 7.47.0-1ubuntu1
    • 7.47.0-1ubuntu2
    • 7.47.0-1ubuntu2.1
    • 7.47.0-1ubuntu2.2
    Affected ranges
    • ECOSYSTEM: < 7.47.0-1ubuntu2.3

    Update to 7.47.0-1ubuntu2.3

Original sources

Check your server →