p PatchFirst

CVE-2016-9809

CVE-2016-9809

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Off-by-one error in the gst_h264_parse_set_caps function in GStreamer before 1.10.2 allows remote attackers to have unspecified impact via a crafted file, which triggers an out-of-bounds read.

CVSS 7.8 · High · EPSS 2.9% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • gst-plugins-bad1.0 Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.10.2-1

    Update to 1.10.2-1

  • gst-plugins-bad1.0 Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.10.2-1

    Update to 1.10.2-1

  • gst-plugins-bad1.0 Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.10.2-1

    Update to 1.10.2-1

  • gst-plugins-bad0.10 Ubuntu:Pro:14.04:LTS

    Versions
    • 0.10.23-7ubuntu2
    • 0.10.23-7.2ubuntu1
    • 0.10.23-7.2ubuntu1.1
    • 0.10.23-7.2ubuntu1.2
    • 0.10.23-7.2ubuntu1.3
    Affected ranges
    • ECOSYSTEM: < 0.10.23-7.2ubuntu1.3+esm1

    Update to 0.10.23-7.2ubuntu1.3+esm1

  • gst-plugins-bad1.0 Ubuntu:Pro:14.04:LTS

    Versions
    • 1.2.0-3ubuntu5
    • 1.2.1-1ubuntu1
    • 1.2.1-1ubuntu2
    • 1.2.2-1ubuntu1
    • 1.2.2-1ubuntu2
    • 1.2.2-1ubuntu4
    • 1.2.3-1ubuntu1
    • 1.2.3-1ubuntu2
    • 1.2.4-1~ubuntu1
    • 1.2.4-1~ubuntu1.1
    • 1.2.4-1~ubuntu1.1+esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • gst-plugins-bad1.0 Ubuntu:Pro:16.04:LTS

    Versions
    • 1.6.0-1ubuntu1
    • 1.6.1-1ubuntu1
    • 1.6.2-1ubuntu1
    • 1.7.1-1ubuntu1
    • 1.7.1-1ubuntu3
    • 1.7.1-1ubuntu4
    • 1.7.2-1ubuntu1
    • 1.7.90-1ubuntu2
    • 1.7.91-1ubuntu1
    • 1.8.0-1ubuntu1
    • 1.8.1-1ubuntu0.1
    • 1.8.2-1ubuntu0.1
    • 1.8.2-1ubuntu0.2
    • 1.8.3-1ubuntu0.2
    • 1.8.3-1ubuntu0.2+esm1
    • 1.8.3-1ubuntu0.2+esm2
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →