CVE-2016-9810
CVE-2016-9810
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The gst_decode_chain_free_internal function in the flxdex decoder in gst-plugins-good in GStreamer before 1.10.2 allows remote attackers to cause a denial of service (invalid memory read and crash) via an invalid file, which triggers an incorrect unref call.
CVSS 5.5 · Medium · EPSS 2.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
gst-plugins-good1.0 Debian:12
- Affected ranges
- ECOSYSTEM: < 1.10.1-2
Update to 1.10.1-2
gst-plugins-good1.0 Debian:13
- Affected ranges
- ECOSYSTEM: < 1.10.1-2
Update to 1.10.1-2
gst-plugins-good1.0 Debian:14
- Affected ranges
- ECOSYSTEM: < 1.10.1-2
Update to 1.10.1-2
gst-plugins-good0.10 Ubuntu:14.04:LTS
- Versions
- 0.10.31-3+nmu1ubuntu3
- 0.10.31-3+nmu1ubuntu4
- 0.10.31-3+nmu1ubuntu5
- 0.10.31-3+nmu1ubuntu5.1
- Affected ranges
- ECOSYSTEM: < 0.10.31-3+nmu1ubuntu5.2
Update to 0.10.31-3+nmu1ubuntu5.2
gst-plugins-good1.0 Ubuntu:14.04:LTS
- Versions
- 1.2.0-1ubuntu1
- 1.2.1-1ubuntu1
- 1.2.1-1ubuntu2
- 1.2.2-1ubuntu1
- 1.2.3-1ubuntu1
- 1.2.3-1ubuntu2
- 1.2.4-1~ubuntu1
- 1.2.4-1~ubuntu1.1
- Affected ranges
- ECOSYSTEM: < 1.2.4-1~ubuntu1.3
Update to 1.2.4-1~ubuntu1.3
gst-plugins-good0.10 Ubuntu:16.04:LTS
- Versions
- 0.10.31-3+nmu4ubuntu2~gcc5.1
- 0.10.31-3+nmu4ubuntu2.16.04.1
- Affected ranges
- ECOSYSTEM: < 0.10.31-3+nmu4ubuntu2.16.04.2
Update to 0.10.31-3+nmu4ubuntu2.16.04.2
gst-plugins-good1.0 Ubuntu:16.04:LTS
- Versions
- 1.6.0-1ubuntu1
- 1.6.1-1ubuntu1
- 1.6.2-1ubuntu1
- 1.7.1-1ubuntu1
- 1.7.2-1ubuntu1
- 1.7.90-1ubuntu1
- 1.7.91-1ubuntu1
- 1.8.0-1ubuntu1
- 1.8.1-1ubuntu0.1
- 1.8.2-1ubuntu0.1
- 1.8.2-1ubuntu0.2
- Affected ranges
- ECOSYSTEM: < 1.8.2-1ubuntu0.3
Update to 1.8.2-1ubuntu0.3
Original sources
- http://www.securityfocus.com/bid/95163
- https://gstreamer.freedesktop.org/releases/1.10/#1.10.2
- https://access.redhat.com/errata/RHSA-2017:2060
- https://bugzilla.gnome.org/show_bug.cgi?id=774897
- http://www.openwall.com/lists/oss-security/2016/12/05/8
- https://security.gentoo.org/glsa/201705-10
- http://www.openwall.com/lists/oss-security/2016/12/01/2
- https://nvd.nist.gov/vuln/detail/CVE-2016-9810