p PatchFirst

PatchFirst · Latest vulnerabilities

gst-plugins-good1.0 vulnerabilities

Vulnerabilities published for gst-plugins-good1.0 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 14

  1. CVE-2016-9636

    Critical · CVSS 9.8EPSS 8.33%Fix available

    CVE-2016-9636

    Heap-based buffer overflow in the flx_decode_delta_fli function in gst/flx/gstflxdec.c in the FLIC decoder in GStreamer before 1.10.2 allows remote attackers to execute arbitrary code or cause a denial of service (application crash) by providing a 'write count' that goes beyond the initialized buffer.

    • Update to 1.8.2-1ubuntu0.2
    Published Updated
  2. CVE-2016-9635

    Critical · CVSS 9.8EPSS 8.84%Fix available

    CVE-2016-9635

    Heap-based buffer overflow in the flx_decode_delta_fli function in gst/flx/gstflxdec.c in the FLIC decoder in GStreamer before 1.10.2 allows remote attackers to execute arbitrary code or cause a denial of service (application crash) by providing a 'skip count' that goes beyond initialized buffer.

    • Update to 1.8.2-1ubuntu0.2
    Published Updated
  3. CVE-2016-9634

    Critical · CVSS 9.8EPSS 8.84%Fix available

    CVE-2016-9634

    Heap-based buffer overflow in the flx_decode_delta_fli function in gst/flx/gstflxdec.c in the FLIC decoder in GStreamer before 1.10.2 allows remote attackers to execute arbitrary code or cause a denial of service (application crash) via the start_line parameter.

    • Update to 1.8.2-1ubuntu0.2
    Published Updated
  4. USN-3135-2

    Not ratedFix available

    gst-plugins-good0.10, gst-plugins-good1.0 vulnerability

    USN-3135-1 fixed a vulnerability in GStreamer Good Plugins. The original security fix was incomplete. This update fixes the problem. Original advisory details: Chris Evans discovered that GStreamer Good Plugins did not correctly handle malformed FLC movie files. If a user were tricked into opening a crafted FLC movie file with a GStreamer application, an attacker could cause a denial of service via application crash, or execute arbitrary code with the privileges of the user invoking the program.

    • Update to 1.8.2-1ubuntu0.3
    Published Updated
  5. USN-3135-1

    Not ratedFix available

    gst-plugins-good0.10, gst-plugins-good1.0 vulnerability

    Chris Evans discovered that GStreamer Good Plugins did not correctly handle malformed FLC movie files. If a user were tricked into opening a crafted FLC movie file with a GStreamer application, an attacker could cause a denial of service via application crash, or execute arbitrary code with the privileges of the user invoking the program.

    • Update to 1.8.2-1ubuntu0.2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →