CVE-2017-0902
CVE-2017-0902
This page contains facts from public vulnerability sources. Check the original advisory before updating.
RubyGems version 2.6.12 and earlier is vulnerable to a DNS hijacking vulnerability that allows a MITM attacker to force the RubyGems client to download and install gems from a server that the attacker controls.
CVSS 8.1 · High · EPSS 4.8% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
rubygems
- Versions
- Versions before 2.6.13: Affected
No fix published
rubygems Debian:12
- Affected ranges
- ECOSYSTEM: < 3.2.0~rc.1-1
Update to 3.2.0~rc.1-1
rubygems Debian:13
- Affected ranges
- ECOSYSTEM: < 3.2.0~rc.1-1
Update to 3.2.0~rc.1-1
rubygems Debian:14
- Affected ranges
- ECOSYSTEM: < 3.2.0~rc.1-1
Update to 3.2.0~rc.1-1
ruby2.0 Ubuntu:14.04:LTS
- Versions
- 2.0.0.299-2
- 2.0.0.343-1
- 2.0.0.343-1ubuntu1
- 2.0.0.353-1
- 2.0.0.353-1ubuntu1
- 2.0.0.484-1ubuntu1
- 2.0.0.484-1ubuntu2
- 2.0.0.484-1ubuntu2.1
- 2.0.0.484-1ubuntu2.2
- 2.0.0.484-1ubuntu2.4
- 2.0.0.484-1ubuntu2.5
- 2.0.0.484-1ubuntu2.6
- 2.0.0.484-1ubuntu2.8
- 2.0.0.484-1ubuntu2.9
- Affected ranges
- ECOSYSTEM: < 2.0.0.484-1ubuntu2.10
Update to 2.0.0.484-1ubuntu2.10
jruby Ubuntu:Pro:14.04:LTS
- Versions
- 1.5.6-5ubuntu1
- 1.5.6-6
- 1.5.6-7
- 1.5.6-9+deb8u2build0.14.04.1~esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ruby2.3 Ubuntu:16.04:LTS
- Versions
- 2.3.0-1
- 2.3.0-2
- 2.3.0-4ubuntu2
- 2.3.0-4ubuntu3
- 2.3.0-5ubuntu1
- 2.3.1-2~16.04
- 2.3.1-2~16.04.2
- 2.3.1-2~16.04.4
- 2.3.1-2~16.04.5
- Affected ranges
- ECOSYSTEM: < 2.3.1-2~16.04.6
Update to 2.3.1-2~16.04.6
jruby Ubuntu:16.04:LTS
- Versions
- 1.7.21-2ubuntu4
- 1.7.22-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
jruby Ubuntu:18.04:LTS
- Versions
- 9.1.13.0-1
- 9.1.17.0-1~18.04
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
jruby Ubuntu:20.04:LTS
- Versions
- 9.1.17.0-3
- 9.1.17.0-3build5
- 9.1.17.0-3build6
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
jruby Ubuntu:24.04:LTS
- Versions
- 9.3.9.0+ds-1
- 9.4.5.0+ds-1
- 9.4.5.0+ds-1ubuntu1
- 9.4.6.0+ds-1ubuntu3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
jruby Ubuntu:25.10
- Versions
- 9.4.8.0+ds-2ubuntu1
- 9.4.8.0+ds-3ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
jruby Ubuntu:26.10
- Versions
- 9.4.8.0+ds-3ubuntu1
- 9.4.14.0+ds-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
jruby Ubuntu:26.04:LTS
- Versions
- 9.4.8.0+ds-3ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://usn.ubuntu.com/3685-1/
- https://usn.ubuntu.com/3553-1/
- https://access.redhat.com/errata/RHSA-2018:0585
- https://www.debian.org/security/2017/dsa-3966
- https://access.redhat.com/errata/RHSA-2018:0378
- http://www.securitytracker.com/id/1039249
- https://access.redhat.com/errata/RHSA-2017:3485
- https://lists.debian.org/debian-lts-announce/2018/07/msg00012.html
- https://access.redhat.com/errata/RHSA-2018:0583
- https://security.gentoo.org/glsa/201710-01
- http://www.securityfocus.com/bid/100586
- https://github.com/rubygems/rubygems/commit/8d91516fb7037ecfb27622f605dc40245e0f8d32
- https://hackerone.com/reports/218088
- http://blog.rubygems.org/2017/08/27/2.6.13-released.html
- https://nvd.nist.gov/vuln/detail/CVE-2017-0902