p PatchFirst

CVE-2017-12871

CVE-2017-12871

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The aesEncrypt method in lib/SimpleSAML/Utils/Crypto.php in SimpleSAMLphp 1.14.x through 1.14.11 makes it easier for context-dependent attackers to bypass the encryption protection mechanism by leveraging use of the first 16 bytes of the secret key as the initialization vector (IV).

CVSS 5.9 · Medium · EPSS 0.5% · Fix available

Published
Updated

Stack: system · php

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • simplesamlphp Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.14.15-1

    Update to 1.14.15-1

  • simplesamlphp Debian:14

    Versions
    • 1.10.0-1
    • 1.11.0-1
    • 1.12.0-1
    • 1.12.0~rc1-1
    • 1.12.0~rc2-1
    • 1.13.0-1
    • 1.13.1-1
    • 1.13.1-2
    • 1.13.2-1
    • 1.14.0-1
    • 1.14.1-1
    • 1.14.10-1
    • 1.14.11-1
    • 1.14.2-1
    • 1.14.2-2
    • 1.14.3-1
    • 1.14.4-1
    • 1.14.5-1
    • 1.14.6-1
    • 1.14.7-1
    • 1.14.8-1
    • 1.14.9-1
    • 1.6.0-1
    • 1.6.1-1
    • 1.6.2-1
    • 1.6.3-1
    • 1.6.3-2
    • 1.6.3-3
    • 1.7.0-1
    • 1.7.0-2
    • 1.8.0-1
    • 1.8.1-1
    • 1.8.2-1
    • 1.9.0-1
    • 1.9.0~rc1-1
    • 1.9.0~rc2-1
    • 1.9.1-1
    • 1.9.2-1
    Affected ranges
    • ECOSYSTEM: < 1.14.15-1

    Update to 1.14.15-1

  • simplesamlphp/simplesamlphp Packagist

    Versions
    • v1.14.0
    • v1.14.1
    • v1.14.10
    • v1.14.11
    • v1.14.2
    • v1.14.3
    • v1.14.4
    • v1.14.5
    • v1.14.6
    • v1.14.7
    • v1.14.8
    • v1.14.9
    Affected ranges
    • ECOSYSTEM: ≥ 1.14.0, < 1.14.12

    Update to 1.14.12

  • simplesamlphp Ubuntu:Pro:16.04:LTS

    Versions
    • 1.13.2-1
    • 1.14.0-1
    • 1.14.0-1ubuntu2
    • 1.14.0-1ubuntu2+esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →