CVE-2017-14160
CVE-2017-14160
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The bark_noise_hybridmp function in psy.c in Xiph.Org libvorbis 1.3.5 allows remote attackers to cause a denial of service (out-of-bounds access and application crash) or possibly have unspecified other impact via a crafted mp4 file.
CVSS 8.8 · High · EPSS 4.6% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
libvorbis Debian:12
- Affected ranges
- ECOSYSTEM: < 1.3.6-2
Update to 1.3.6-2
libvorbis Debian:13
- Affected ranges
- ECOSYSTEM: < 1.3.6-2
Update to 1.3.6-2
libvorbis Debian:14
- Affected ranges
- ECOSYSTEM: < 1.3.6-2
Update to 1.3.6-2
libvorbis Ubuntu:Pro:16.04:LTS
- Versions
- 1.3.4-2
- 1.3.4-3
- 1.3.5-2
- 1.3.5-3
- 1.3.5-3ubuntu0.1
- 1.3.5-3ubuntu0.2
- Affected ranges
- ECOSYSTEM: < 1.3.5-3ubuntu0.2+esm1
Update to 1.3.5-3ubuntu0.2+esm1
libvorbis Ubuntu:18.04:LTS
- Versions
- 1.3.5-4
- 1.3.5-4.1
- 1.3.5-4.2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- http://www.securityfocus.com/bid/101045
- http://openwall.com/lists/oss-security/2017/09/21/2
- https://lists.debian.org/debian-lts-announce/2019/11/msg00031.html
- https://security.gentoo.org/glsa/202003-36
- https://lists.debian.org/debian-lts-announce/2021/11/msg00023.html
- https://nvd.nist.gov/vuln/detail/CVE-2017-14160