CVE-2017-18122
CVE-2017-18122
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A signature-validation bypass issue was discovered in SimpleSAMLphp through 1.14.16. A SimpleSAMLphp Service Provider using SAML 1.1 will regard as valid any unsigned SAML response containing more than one signed assertion, provided that the signature of at least one of the assertions is valid. Attributes contained in all the assertions received will be merged and the entityID of the first assertion received will be used, allowing an attacker to impersonate any user of any IdP given an assertion signed by the targeted IdP.
CVSS 8.1 · High · EPSS 1.1% · Fix available
- Published
- Updated
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
simplesamlphp Debian:12
- Affected ranges
- ECOSYSTEM: < 1.15.0-1
Update to 1.15.0-1
simplesamlphp Debian:14
- Versions
- 1.10.0-1
- 1.11.0-1
- 1.12.0-1
- 1.12.0~rc1-1
- 1.12.0~rc2-1
- 1.13.0-1
- 1.13.1-1
- 1.13.1-2
- 1.13.2-1
- 1.14.0-1
- 1.14.1-1
- 1.14.10-1
- 1.14.11-1
- 1.14.15-1
- 1.14.2-1
- 1.14.2-2
- 1.14.3-1
- 1.14.4-1
- 1.14.5-1
- 1.14.6-1
- 1.14.7-1
- 1.14.8-1
- 1.14.9-1
- 1.6.0-1
- 1.6.1-1
- 1.6.2-1
- 1.6.3-1
- 1.6.3-2
- 1.6.3-3
- 1.7.0-1
- 1.7.0-2
- 1.8.0-1
- 1.8.1-1
- 1.8.2-1
- 1.9.0-1
- 1.9.0~rc1-1
- 1.9.0~rc2-1
- 1.9.1-1
- 1.9.2-1
- Affected ranges
- ECOSYSTEM: < 1.15.0-1
Update to 1.15.0-1
simplesamlphp/simplesamlphp Packagist
- Versions
- v1.12.0
- v1.13.0
- v1.13.0-rc1
- v1.13.0-rc2
- v1.13.1
- v1.13.2
- v1.14.0
- v1.14.0-rc1
- v1.14.1
- v1.14.10
- v1.14.11
- v1.14.12
- v1.14.13
- v1.14.14
- v1.14.15
- v1.14.16
- v1.14.2
- v1.14.3
- v1.14.4
- v1.14.5
- v1.14.6
- v1.14.7
- v1.14.8
- v1.14.9
- Affected ranges
- ECOSYSTEM: < 1.14.17
Update to 1.14.17
simplesamlphp Ubuntu:Pro:16.04:LTS
- Versions
- 1.13.2-1
- 1.14.0-1
- 1.14.0-1ubuntu2
- 1.14.0-1ubuntu2+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published