p PatchFirst

CVE-2017-18269

CVE-2017-18269

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An SSE2-optimized memmove implementation for i386 in sysdeps/i386/i686/multiarch/memcpy-sse2-unaligned.S in the GNU C Library (aka glibc or libc6) 2.21 through 2.27 does not correctly perform the overlapping memory check if the source memory range spans the middle of the address space, resulting in corrupt data being produced by the copy operation. This may disclose information to context-dependent attackers, or result in a denial of service, or, possibly, code execution.

CVSS 9.8 · Critical · EPSS 4.6% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • glibc Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.27-3

    Update to 2.27-3

  • glibc Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.27-3

    Update to 2.27-3

  • glibc Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.27-3

    Update to 2.27-3

  • glibc Ubuntu:16.04:LTS

    Versions
    • 2.21-0ubuntu4
    • 2.21-0ubuntu5
    • 2.21-0ubuntu6
    • 2.23-0ubuntu1
    • 2.23-0ubuntu2
    • 2.23-0ubuntu3
    • 2.23-0ubuntu4
    • 2.23-0ubuntu5
    • 2.23-0ubuntu6
    • 2.23-0ubuntu7
    • 2.23-0ubuntu9
    • 2.23-0ubuntu10
    • 2.23-0ubuntu11
    Affected ranges
    • ECOSYSTEM: < 2.23-0ubuntu11.2

    Update to 2.23-0ubuntu11.2

Original sources

Check your server →