p PatchFirst

PatchFirst · Latest vulnerabilities

glibc vulnerabilities

Vulnerabilities published for glibc in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 24

  1. CVE-2020-1752

    High · CVSS 7EPSS 0.55%Fix available

    CVE-2020-1752

    A use-after-free vulnerability introduced in glibc upstream version 2.14 was found in the way the tilde expansion was carried out. Directory paths containing an initial tilde followed by a valid username were affected by this issue. A local attacker could exploit this flaw by creating a specially crafted path that, when processed by the glob function, would potentially lead to arbitrary code execution. This was fixed in version 2.32.

    • Update to 2.23-0ubuntu11.2
    Published Updated
  2. CVE-2020-1751

    Medium · CVSS 5.1EPSS 0.54%Fix available

    CVE-2020-1751

    An out-of-bounds write vulnerability was found in glibc before 2.31 when handling signal trampolines on PowerPC. Specifically, the backtrace function did not properly check the array bounds when storing the frame address, resulting in a denial of service or potential code execution. The highest threat from this vulnerability is to system availability.

    • Update to 2.23-0ubuntu11.2
    Published Updated
  3. CVE-2020-6096

    High · CVSS 8.1EPSS 5.48%Fix available

    CVE-2020-6096

    An exploitable signed comparison vulnerability exists in the ARMv7 memcpy() implementation of GNU glibc 2.30.9000. Calling memcpy() (on ARMv7 targets that utilize the GNU glibc implementation) with a negative value for the 'num' parameter results in a signed comparison vulnerability. If an attacker underflows the 'num' parameter to memcpy(), this vulnerability could lead to undefined behavior such as writing to out-of-bounds memory and potentially remote code execution. Furthermore, this memcpy() implementation allows for program execution to continue in scenarios where a segmentation fault or crash should have occurred. The dangers occur in

    • Update to 2.23-0ubuntu11.3
    Published Updated
  4. CVE-2020-10029

    Medium · CVSS 5.5EPSS 0.76%Fix available

    CVE-2020-10029

    The GNU C Library (aka glibc or libc6) before 2.32 could overflow an on-stack buffer during range reduction if an input to an 80-bit long double function contains a non-canonical bit pattern, a seen when passing a 0x5d414141414141410000 value to sinl on x86 targets. This is related to sysdeps/ieee754/ldbl-96/e_rem_pio2l.c.

    • Update to 2.23-0ubuntu11.2
    Published Updated
  5. CVE-2019-19126

    Low · CVSS 3.3EPSS 0.41%Fix available

    CVE-2019-19126

    On the x86-64 architecture, the GNU C Library (aka glibc) before 2.31 fails to ignore the LD_PREFER_MAP_32BIT_EXEC environment variable during program execution after a security transition, allowing local attackers to restrict the possible mapping addresses for loaded libraries and thus bypass ASLR for a setuid program.

    • Update to 2.23-0ubuntu11.2
    Published Updated
  6. CVE-2009-5155

    High · CVSS 7.5EPSS 3.91%Fix available

    CVE-2009-5155

    In the GNU C Library (aka glibc or libc6) before 2.28, parse_reg_exp in posix/regcomp.c misparses alternatives, which allows attackers to cause a denial of service (assertion failure and application exit) or trigger an incorrect result by attempting a regular-expression match.

    • Update to 2.23-0ubuntu11.3
    Published Updated
  7. CVE-2018-11236

    Critical · CVSS 9.8EPSS 6.92%Fix available

    CVE-2018-11236

    stdlib/canonicalize.c in the GNU C Library (aka glibc or libc6) 2.27 and earlier, when processing very long pathname arguments to the realpath function, could encounter an integer overflow on 32-bit architectures, leading to a stack-based buffer overflow and, potentially, arbitrary code execution.

    • Update to 2.23-0ubuntu11.2
    Published Updated
  8. CVE-2017-18269

    Critical · CVSS 9.8EPSS 4.54%Fix available

    CVE-2017-18269

    An SSE2-optimized memmove implementation for i386 in sysdeps/i386/i686/multiarch/memcpy-sse2-unaligned.S in the GNU C Library (aka glibc or libc6) 2.21 through 2.27 does not correctly perform the overlapping memory check if the source memory range spans the middle of the address space, resulting in corrupt data being produced by the copy operation. This may disclose information to context-dependent attackers, or result in a denial of service, or, possibly, code execution.

    • Update to 2.23-0ubuntu11.2
    Published Updated
  9. CVE-2018-6485

    Critical · CVSS 9.8EPSS 4.69%Fix available

    CVE-2018-6485

    An integer overflow in the implementation of the posix_memalign in memalign functions in the GNU C Library (aka glibc or libc6) 2.26 and earlier could cause these functions to return a pointer to a heap area that is too small, potentially leading to heap corruption.

    • Update to 2.23-0ubuntu11.2
    Published Updated
  10. CVE-2017-16997

    High · CVSS 7.8EPSS 2.9%Fix available

    CVE-2017-16997

    elf/dl-load.c in the GNU C Library (aka glibc or libc6) 2.19 through 2.26 mishandles RPATH and RUNPATH containing $ORIGIN for a privileged (setuid or AT_SECURE) program, which allows local users to gain privileges via a Trojan horse library in the current working directory, related to the fillin_rpath and decompose_rpath functions. This is associated with misinterpretion of an empty RPATH/RUNPATH token as the "./" directory. NOTE: this configuration of RPATH/RUNPATH for a privileged program is apparently very uncommon; most likely, no such program is shipped with any common Linux distribution.

    • Update to 2.23-0ubuntu10
    Published Updated
  11. CVE-2017-1000366

    High · CVSS 7.8EPSS 2.73%Public exploitFix available

    CVE-2017-1000366

    glibc contains a vulnerability that allows specially crafted LD_LIBRARY_PATH values to manipulate the heap/stack, causing them to alias, potentially resulting in arbitrary code execution. Please note that additional hardening changes have been made to glibc to prevent manipulation of stack and heap memory but these issues are not directly exploitable, as such they have not been given a CVE. This affects glibc 2.25 and earlier.

    • Update to 2.23-0ubuntu9
    Published Updated
  12. CVE-2016-5417

    High · CVSS 7.5EPSS 3.36%Fix available

    CVE-2016-5417

    Memory leak in the __res_vinit function in the IPv6 name server management code in libresolv in GNU C Library (aka glibc or libc6) before 2.24 allows remote attackers to cause a denial of service (memory consumption) by leveraging partial initialization of internal resolver data structures.

    • Update to 2.23-0ubuntu6
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →