p PatchFirst

CVE-2017-3736

CVE-2017-3736

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

There is a carry propagating bug in the x86_64 Montgomery squaring procedure in OpenSSL before 1.0.2m and 1.1.0 before 1.1.0g. No EC algorithms are affected. Analysis suggests that attacks against RSA and DSA as a result of this defect would be very difficult to perform and are not believed likely. Attacks against DH are considered just feasible (although very difficult) because most of the work necessary to deduce information about a private key may be performed offline. The amount of resources required for such an attack would be very significant and likely only accessible to a limited number of attackers. An attacker would additionally need online access to an unpatched system using the target private key in a scenario with persistent DH parameters and a private key that is shared between multiple clients. This only affects processors that support the BMI1, BMI2 and ADX extensions like Intel Broadwell (5th generation) and later or AMD Ryzen.

CVSS 6.5 · Medium · EPSS 10.1% · Fix available

Published
Updated

Stack: system · network

Affected products and versions

  • openssl

    Versions
    • 1.1.0 - 1.1.0f: Affected
    • 1.0.2 - 1.0.2l: Affected

    No fix published

  • openssl Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.1.0g-1

    Update to 1.1.0g-1

  • openssl Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.1.0g-1

    Update to 1.1.0g-1

  • openssl Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.1.0g-1

    Update to 1.1.0g-1

  • openssl Ubuntu:16.04:LTS

    Versions
    • 1.0.2d-0ubuntu1
    • 1.0.2d-0ubuntu2
    • 1.0.2e-1ubuntu1
    • 1.0.2f-2ubuntu1
    • 1.0.2g-1ubuntu2
    • 1.0.2g-1ubuntu3
    • 1.0.2g-1ubuntu4
    • 1.0.2g-1ubuntu4.1
    • 1.0.2g-1ubuntu4.2
    • 1.0.2g-1ubuntu4.4
    • 1.0.2g-1ubuntu4.5
    • 1.0.2g-1ubuntu4.6
    • 1.0.2g-1ubuntu4.8
    Affected ranges
    • ECOSYSTEM: < 1.0.2g-1ubuntu4.9

    Update to 1.0.2g-1ubuntu4.9

  • openssl Ubuntu:18.04:LTS

    Versions
    • 1.0.2g-1ubuntu13
    Affected ranges
    • ECOSYSTEM: < 1.0.2g-1ubuntu14

    Update to 1.0.2g-1ubuntu14

Original sources

Check your server →