p PatchFirst

CVE-2017-5334

CVE-2017-5334

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Double free vulnerability in the gnutls_x509_ext_import_proxy function in GnuTLS before 3.3.26 and 3.5.x before 3.5.8 allows remote attackers to have unspecified impact via crafted policy language information in an X.509 certificate with a Proxy Certificate Information extension.

CVSS 9.8 · Critical · EPSS 32.8% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • gnutls28 Debian:12

    Affected ranges
    • ECOSYSTEM: < 3.5.8-1

    Update to 3.5.8-1

  • gnutls28 Debian:13

    Affected ranges
    • ECOSYSTEM: < 3.5.8-1

    Update to 3.5.8-1

  • gnutls28 Debian:14

    Affected ranges
    • ECOSYSTEM: < 3.5.8-1

    Update to 3.5.8-1

  • gnutls28 Ubuntu:16.04:LTS

    Versions
    • 3.3.15-5ubuntu2
    • 3.3.18-1ubuntu1
    • 3.3.20-1ubuntu1
    • 3.4.9-2ubuntu1
    • 3.4.10-4ubuntu1
    • 3.4.10-4ubuntu1.1
    Affected ranges
    • ECOSYSTEM: < 3.4.10-4ubuntu1.2

    Update to 3.4.10-4ubuntu1.2

Original sources

Check your server →