CVE-2017-5336
CVE-2017-5336
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Stack-based buffer overflow in the cdk_pk_get_keyid function in lib/opencdk/pubkey.c in GnuTLS before 3.3.26 and 3.5.x before 3.5.8 allows remote attackers to have unspecified impact via a crafted OpenPGP certificate.
CVSS 9.8 · Critical · EPSS 7.1% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
gnutls28 Debian:12
- Affected ranges
- ECOSYSTEM: < 3.5.8-1
Update to 3.5.8-1
gnutls28 Debian:13
- Affected ranges
- ECOSYSTEM: < 3.5.8-1
Update to 3.5.8-1
gnutls28 Debian:14
- Affected ranges
- ECOSYSTEM: < 3.5.8-1
Update to 3.5.8-1
gnutls26 Ubuntu:14.04:LTS
- Versions
- 2.12.23-1ubuntu4
- 2.12.23-1ubuntu5
- 2.12.23-12ubuntu1
- 2.12.23-12ubuntu2
- 2.12.23-12ubuntu2.1
- 2.12.23-12ubuntu2.2
- 2.12.23-12ubuntu2.3
- 2.12.23-12ubuntu2.4
- 2.12.23-12ubuntu2.5
- Affected ranges
- ECOSYSTEM: < 2.12.23-12ubuntu2.6
Update to 2.12.23-12ubuntu2.6
gnutls28 Ubuntu:16.04:LTS
- Versions
- 3.3.15-5ubuntu2
- 3.3.18-1ubuntu1
- 3.3.20-1ubuntu1
- 3.4.9-2ubuntu1
- 3.4.10-4ubuntu1
- 3.4.10-4ubuntu1.1
- Affected ranges
- ECOSYSTEM: < 3.4.10-4ubuntu1.2
Update to 3.4.10-4ubuntu1.2
Original sources
- https://gitlab.com/gnutls/gnutls/commit/5140422e0d7319a8e2fe07f02cbcafc4d6538732
- http://www.securityfocus.com/bid/95377
- http://www.openwall.com/lists/oss-security/2017/01/10/7
- https://access.redhat.com/errata/RHSA-2017:2292
- http://www.securitytracker.com/id/1037576
- http://www.openwall.com/lists/oss-security/2017/01/11/4
- http://lists.opensuse.org/opensuse-security-announce/2017-02/msg00005.html
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=340
- http://rhn.redhat.com/errata/RHSA-2017-0574.html
- https://security.gentoo.org/glsa/201702-04
- https://gnutls.org/security.html#GNUTLS-SA-2017-2
- https://nvd.nist.gov/vuln/detail/CVE-2017-5336