p PatchFirst

CVE-2017-5840

CVE-2017-5840

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The qtdemux_parse_samples function in gst/isomp4/qtdemux.c in gst-plugins-good in GStreamer before 1.10.3 allows remote attackers to cause a denial of service (out-of-bounds heap read) via vectors involving the current stts index.

CVSS 7.5 · High · EPSS 4.7% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • gst-plugins-good1.0 Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.10.3-1

    Update to 1.10.3-1

  • gst-plugins-good1.0 Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.10.3-1

    Update to 1.10.3-1

  • gst-plugins-good1.0 Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.10.3-1

    Update to 1.10.3-1

  • gst-plugins-good0.10 Ubuntu:14.04:LTS

    Versions
    • 0.10.31-3+nmu1ubuntu3
    • 0.10.31-3+nmu1ubuntu4
    • 0.10.31-3+nmu1ubuntu5
    • 0.10.31-3+nmu1ubuntu5.1
    • 0.10.31-3+nmu1ubuntu5.2
    Affected ranges
    • ECOSYSTEM: < 0.10.31-3+nmu1ubuntu5.3

    Update to 0.10.31-3+nmu1ubuntu5.3

  • gst-plugins-good1.0 Ubuntu:14.04:LTS

    Versions
    • 1.2.0-1ubuntu1
    • 1.2.1-1ubuntu1
    • 1.2.1-1ubuntu2
    • 1.2.2-1ubuntu1
    • 1.2.3-1ubuntu1
    • 1.2.3-1ubuntu2
    • 1.2.4-1~ubuntu1
    • 1.2.4-1~ubuntu1.1
    • 1.2.4-1~ubuntu1.3
    Affected ranges
    • ECOSYSTEM: < 1.2.4-1~ubuntu1.4

    Update to 1.2.4-1~ubuntu1.4

  • gst-plugins-good0.10 Ubuntu:16.04:LTS

    Versions
    • 0.10.31-3+nmu4ubuntu2~gcc5.1
    • 0.10.31-3+nmu4ubuntu2.16.04.1
    • 0.10.31-3+nmu4ubuntu2.16.04.2
    Affected ranges
    • ECOSYSTEM: < 0.10.31-3+nmu4ubuntu2.16.04.3

    Update to 0.10.31-3+nmu4ubuntu2.16.04.3

  • gst-plugins-good1.0 Ubuntu:16.04:LTS

    Versions
    • 1.6.0-1ubuntu1
    • 1.6.1-1ubuntu1
    • 1.6.2-1ubuntu1
    • 1.7.1-1ubuntu1
    • 1.7.2-1ubuntu1
    • 1.7.90-1ubuntu1
    • 1.7.91-1ubuntu1
    • 1.8.0-1ubuntu1
    • 1.8.1-1ubuntu0.1
    • 1.8.2-1ubuntu0.1
    • 1.8.2-1ubuntu0.2
    • 1.8.2-1ubuntu0.3
    • 1.8.3-1ubuntu0.3
    Affected ranges
    • ECOSYSTEM: < 1.8.3-1ubuntu0.4

    Update to 1.8.3-1ubuntu0.4

Original sources

Check your server →