p PatchFirst

CVE-2017-5841

CVE-2017-5841

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The gst_avi_demux_parse_ncdt function in gst/avi/gstavidemux.c in gst-plugins-good in GStreamer before 1.10.3 allows remote attackers to cause a denial of service (out-of-bounds heap read) via vectors involving ncdt tags.

CVSS 7.5 · High · EPSS 3.8% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • gst-plugins-good1.0 Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.10.3-1

    Update to 1.10.3-1

  • gst-plugins-good1.0 Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.10.3-1

    Update to 1.10.3-1

  • gst-plugins-good1.0 Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.10.3-1

    Update to 1.10.3-1

  • gst-plugins-good1.0 Ubuntu:16.04:LTS

    Versions
    • 1.6.0-1ubuntu1
    • 1.6.1-1ubuntu1
    • 1.6.2-1ubuntu1
    • 1.7.1-1ubuntu1
    • 1.7.2-1ubuntu1
    • 1.7.90-1ubuntu1
    • 1.7.91-1ubuntu1
    • 1.8.0-1ubuntu1
    • 1.8.1-1ubuntu0.1
    • 1.8.2-1ubuntu0.1
    • 1.8.2-1ubuntu0.2
    • 1.8.2-1ubuntu0.3
    • 1.8.3-1ubuntu0.3
    Affected ranges
    • ECOSYSTEM: < 1.8.3-1ubuntu0.4

    Update to 1.8.3-1ubuntu0.4

Original sources

Check your server →