CVE-2017-6004
CVE-2017-6004
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The compile_bracket_matchingpath function in pcre_jit_compile.c in PCRE through 8.x before revision 1680 (e.g., the PHP 7.1.1 bundled version) allows remote attackers to cause a denial of service (out-of-bounds read and application crash) via a crafted regular expression.
CVSS 7.5 · High · EPSS 4.5% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
pcre3 Debian:12
- Affected ranges
- ECOSYSTEM: < 2:8.39-2.1
Update to 2:8.39-2.1
pcre3 Ubuntu:Pro:16.04:LTS
- Versions
- 2:8.35-7.1ubuntu1
- 2:8.38-1ubuntu1
- 2:8.38-3
- 2:8.38-3.1
- 2:8.38-3.1ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: < 2:8.38-3.1ubuntu0.1~esm2
Update to 2:8.38-3.1ubuntu0.1~esm2
Original sources
- https://vcs.pcre.org/pcre/code/trunk/pcre_jit_compile.c?r1=1676&r2=1680&view=patch
- https://security.gentoo.org/glsa/201706-11
- http://www.securitytracker.com/id/1037850
- http://www.securityfocus.com/bid/96295
- https://access.redhat.com/errata/RHSA-2018:2486
- https://bugs.exim.org/show_bug.cgi?id=2035
- https://lists.apache.org/thread.html/rf4c02775860db415b4955778a131c2795223f61cb8c6a450893651e4%40%3Cissues.bookkeeper.apache.org%3E
- https://lists.apache.org/thread.html/r58af02e294bd07f487e2c64ffc0a29b837db5600e33b6e698b9d696b%40%3Cissues.bookkeeper.apache.org%3E
- https://nvd.nist.gov/vuln/detail/CVE-2017-6004