CVE-2017-7507
CVE-2017-7507
This page contains facts from public vulnerability sources. Check the original advisory before updating.
GnuTLS version 3.5.12 and earlier is vulnerable to a NULL pointer dereference while decoding a status response TLS extension with valid contents. This could lead to a crash of the GnuTLS server application.
CVSS 7.5 · High · EPSS 3.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
gnutls
- Versions
- 3.5.12: Affected
No fix published
gnutls28 Debian:12
- Affected ranges
- ECOSYSTEM: < 3.5.8-6
Update to 3.5.8-6
gnutls28 Debian:13
- Affected ranges
- ECOSYSTEM: < 3.5.8-6
Update to 3.5.8-6
gnutls28 Debian:14
- Affected ranges
- ECOSYSTEM: < 3.5.8-6
Update to 3.5.8-6
gnutls28 Ubuntu:16.04:LTS
- Versions
- 3.3.15-5ubuntu2
- 3.3.18-1ubuntu1
- 3.3.20-1ubuntu1
- 3.4.9-2ubuntu1
- 3.4.10-4ubuntu1
- 3.4.10-4ubuntu1.1
- 3.4.10-4ubuntu1.2
- Affected ranges
- ECOSYSTEM: < 3.4.10-4ubuntu1.3
Update to 3.4.10-4ubuntu1.3