p PatchFirst

CVE-2017-8817

CVE-2017-8817

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The FTP wildcard function in curl and libcurl before 7.57.0 allows remote attackers to cause a denial of service (out-of-bounds read and application crash) or possibly have unspecified other impact via a string that ends with an '[' character.

CVSS 9.8 · Critical · EPSS 11.2% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • curl and libcurl before 7.57.0

    Versions
    • curl and libcurl before 7.57.0: Affected

    No fix published

  • curl Debian:12

    Affected ranges
    • ECOSYSTEM: < 7.57.0-1

    Update to 7.57.0-1

  • curl Debian:13

    Affected ranges
    • ECOSYSTEM: < 7.57.0-1

    Update to 7.57.0-1

  • curl Debian:14

    Affected ranges
    • ECOSYSTEM: < 7.57.0-1

    Update to 7.57.0-1

  • curl Ubuntu:14.04:LTS

    Versions
    • 7.32.0-1ubuntu1
    • 7.33.0-1ubuntu1
    • 7.34.0-1ubuntu1
    • 7.35.0-1ubuntu1
    • 7.35.0-1ubuntu2
    • 7.35.0-1ubuntu2.1
    • 7.35.0-1ubuntu2.2
    • 7.35.0-1ubuntu2.3
    • 7.35.0-1ubuntu2.5
    • 7.35.0-1ubuntu2.6
    • 7.35.0-1ubuntu2.7
    • 7.35.0-1ubuntu2.8
    • 7.35.0-1ubuntu2.9
    • 7.35.0-1ubuntu2.10
    • 7.35.0-1ubuntu2.11
    • 7.35.0-1ubuntu2.12
    Affected ranges
    • ECOSYSTEM: < 7.35.0-1ubuntu2.13

    Update to 7.35.0-1ubuntu2.13

  • curl Ubuntu:16.04:LTS

    Versions
    • 7.43.0-1ubuntu2
    • 7.45.0-1ubuntu1
    • 7.46.0-1ubuntu1
    • 7.47.0-1ubuntu1
    • 7.47.0-1ubuntu2
    • 7.47.0-1ubuntu2.1
    • 7.47.0-1ubuntu2.2
    • 7.47.0-1ubuntu2.3
    • 7.47.0-1ubuntu2.4
    Affected ranges
    • ECOSYSTEM: < 7.47.0-1ubuntu2.5

    Update to 7.47.0-1ubuntu2.5

Original sources

Check your server →