p PatchFirst

CVE-2017-9050

CVE-2017-9050

This page contains facts from public vulnerability sources. Check the original advisory before updating.

libxml2 20904-GITv2.9.4-16-g0741801 is vulnerable to a heap-based buffer over-read in the xmlDictAddString function in dict.c. This vulnerability causes programs that use libxml2, such as PHP, to crash. This vulnerability exists because of an incomplete fix for CVE-2016-1839.

CVSS 7.5 · High · EPSS 4.6% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • libxml2 Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.9.4+dfsg1-3.1

    Update to 2.9.4+dfsg1-3.1

  • libxml2 Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.9.4+dfsg1-3.1

    Update to 2.9.4+dfsg1-3.1

  • libxml2 Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.9.4+dfsg1-3.1

    Update to 2.9.4+dfsg1-3.1

  • libxml2 Ubuntu:14.04:LTS

    Versions
    • 2.9.1+dfsg1-3ubuntu2
    • 2.9.1+dfsg1-3ubuntu3
    • 2.9.1+dfsg1-3ubuntu4
    • 2.9.1+dfsg1-3ubuntu4.1
    • 2.9.1+dfsg1-3ubuntu4.2
    • 2.9.1+dfsg1-3ubuntu4.3
    • 2.9.1+dfsg1-3ubuntu4.4
    • 2.9.1+dfsg1-3ubuntu4.5
    • 2.9.1+dfsg1-3ubuntu4.6
    • 2.9.1+dfsg1-3ubuntu4.7
    • 2.9.1+dfsg1-3ubuntu4.8
    • 2.9.1+dfsg1-3ubuntu4.9
    Affected ranges
    • ECOSYSTEM: < 2.9.1+dfsg1-3ubuntu4.10

    Update to 2.9.1+dfsg1-3ubuntu4.10

  • libxml2 Ubuntu:16.04:LTS

    Versions
    • 2.9.2+zdfsg1-4
    • 2.9.2+zdfsg1-4ubuntu1
    • 2.9.2+zdfsg1-4ubuntu2
    • 2.9.2+zdfsg1-4ubuntu3
    • 2.9.3+dfsg1-1
    • 2.9.3+dfsg1-1ubuntu0.1
    • 2.9.3+dfsg1-1ubuntu0.2
    Affected ranges
    • ECOSYSTEM: < 2.9.3+dfsg1-1ubuntu0.3

    Update to 2.9.3+dfsg1-1ubuntu0.3

Original sources

Check your server →