CVE-2018-1000079
CVE-2018-1000079
This page contains facts from public vulnerability sources. Check the original advisory before updating.
RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Directory Traversal vulnerability in gem installation that can result in the gem could write to arbitrary filesystem locations during installation. This attack appear to be exploitable via the victim must install a malicious gem. This vulnerability appears to have been fixed in 2.7.6.
CVSS 5.5 · Medium · EPSS 2.8% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
jruby Debian:12
- Affected ranges
- ECOSYSTEM: < 9.1.17.0-1
Update to 9.1.17.0-1
jruby Debian:13
- Affected ranges
- ECOSYSTEM: < 9.1.17.0-1
Update to 9.1.17.0-1
jruby Debian:14
- Affected ranges
- ECOSYSTEM: < 9.1.17.0-1
Update to 9.1.17.0-1
rubygems Debian:12
- Affected ranges
- ECOSYSTEM: < 3.2.0~rc.1-1
Update to 3.2.0~rc.1-1
rubygems Debian:13
- Affected ranges
- ECOSYSTEM: < 3.2.0~rc.1-1
Update to 3.2.0~rc.1-1
rubygems Debian:14
- Affected ranges
- ECOSYSTEM: < 3.2.0~rc.1-1
Update to 3.2.0~rc.1-1
ruby2.0 Ubuntu:14.04:LTS
- Versions
- 2.0.0.299-2
- 2.0.0.343-1
- 2.0.0.343-1ubuntu1
- 2.0.0.353-1
- 2.0.0.353-1ubuntu1
- 2.0.0.484-1ubuntu1
- 2.0.0.484-1ubuntu2
- 2.0.0.484-1ubuntu2.1
- 2.0.0.484-1ubuntu2.2
- 2.0.0.484-1ubuntu2.4
- 2.0.0.484-1ubuntu2.5
- Affected ranges
- ECOSYSTEM: < 2.0.0.484-1ubuntu2.6
Update to 2.0.0.484-1ubuntu2.6
jruby Ubuntu:Pro:14.04:LTS
- Versions
- 1.5.6-5ubuntu1
- 1.5.6-6
- 1.5.6-7
- 1.5.6-9+deb8u2build0.14.04.1~esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ruby2.3 Ubuntu:16.04:LTS
- Versions
- 2.3.0-1
- 2.3.0-2
- 2.3.0-4ubuntu2
- 2.3.0-4ubuntu3
- 2.3.0-5ubuntu1
- 2.3.1-2~16.04
- 2.3.1-2~16.04.2
- 2.3.1-2~16.04.4
- 2.3.1-2~16.04.5
- 2.3.1-2~16.04.6
- Affected ranges
- ECOSYSTEM: < 2.3.1-2~16.04.7
Update to 2.3.1-2~16.04.7
jruby Ubuntu:16.04:LTS
- Versions
- 1.7.21-2ubuntu4
- 1.7.22-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
jruby Ubuntu:18.04:LTS
- Versions
- 9.1.13.0-1
- 9.1.17.0-1~18.04
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://www.debian.org/security/2018/dsa-4219
- https://usn.ubuntu.com/3621-1/
- https://access.redhat.com/errata/RHSA-2018:3729
- https://github.com/rubygems/rubygems/commit/666ef793cad42eed96f7aee1cdf77865db921099
- https://access.redhat.com/errata/RHSA-2018:3730
- https://access.redhat.com/errata/RHSA-2018:3731
- https://lists.debian.org/debian-lts-announce/2018/07/msg00012.html
- https://www.debian.org/security/2018/dsa-4259
- https://github.com/rubygems/rubygems/commit/f83f911e19e27cbac1ccce7471d96642241dd759
- http://blog.rubygems.org/2018/02/15/2.7.6-released.html
- http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00036.html
- https://access.redhat.com/errata/RHSA-2019:2028
- https://access.redhat.com/errata/RHSA-2020:0542
- https://access.redhat.com/errata/RHSA-2020:0591
- https://access.redhat.com/errata/RHSA-2020:0663
- https://nvd.nist.gov/vuln/detail/CVE-2018-1000079