CVE-2018-1054
CVE-2018-1054
This page contains facts from public vulnerability sources. Check the original advisory before updating.
An out-of-bounds memory read flaw was found in the way 389-ds-base handled certain LDAP search filters, affecting all versions including 1.4.x. A remote, unauthenticated attacker could potentially use this flaw to make ns-slapd crash via a specially crafted LDAP request, thus resulting in denial of service.
CVSS 7.5 · High · EPSS 4.6% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
389-ds-base
- Versions
- all versions including upstream 1.4.x: Affected
No fix published
389-ds-base Debian:12
- Affected ranges
- ECOSYSTEM: < 1.3.7.10-1
Update to 1.3.7.10-1
389-ds-base Debian:13
- Affected ranges
- ECOSYSTEM: < 1.3.7.10-1
Update to 1.3.7.10-1
389-ds-base Ubuntu:Pro:16.04:LTS
- Versions
- 1.3.3.12-1build1
- 1.3.3.13-1
- 1.3.4.5-2
- 1.3.4.8-1
- 1.3.4.8-3
- 1.3.4.8-3ubuntu1
- 1.3.4.8-4
- 1.3.4.9-1
- 1.3.4.9-1ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
389-ds-base Ubuntu:18.04:LTS
- Versions
- 1.3.7.5-1
- 1.3.7.5-1build1
- 1.3.7.5-1build2
- 1.3.7.9-1
- Affected ranges
- ECOSYSTEM: < 1.3.7.10-1
Update to 1.3.7.10-1
389-ds-base Ubuntu:26.04:LTS
- Versions
- 3.1.2+dfsg1-1
- 3.1.2+vendor1-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://pagure.io/389-ds-base/issue/49545
- https://bugzilla.redhat.com/show_bug.cgi?id=1537314
- https://access.redhat.com/errata/RHSA-2018:0414
- https://access.redhat.com/errata/RHSA-2018:0515
- https://lists.debian.org/debian-lts-announce/2018/07/msg00018.html
- http://www.securityfocus.com/bid/103228
- https://nvd.nist.gov/vuln/detail/CVE-2018-1054