p PatchFirst

CVE-2018-11237

CVE-2018-11237

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An AVX-512-optimized implementation of the mempcpy function in the GNU C Library (aka glibc or libc6) 2.27 and earlier may write data beyond the target buffer, leading to a buffer overflow in __mempcpy_avx512_no_vzeroupper.

CVSS 7.8 · High · EPSS 0.9% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • glibc Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.27-4

    Update to 2.27-4

  • glibc Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.27-4

    Update to 2.27-4

  • glibc Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.27-4

    Update to 2.27-4

  • glibc Ubuntu:16.04:LTS

    Versions
    • 2.21-0ubuntu4
    • 2.21-0ubuntu5
    • 2.21-0ubuntu6
    • 2.23-0ubuntu1
    • 2.23-0ubuntu2
    • 2.23-0ubuntu3
    • 2.23-0ubuntu4
    • 2.23-0ubuntu5
    • 2.23-0ubuntu6
    • 2.23-0ubuntu7
    • 2.23-0ubuntu9
    • 2.23-0ubuntu10
    • 2.23-0ubuntu11
    Affected ranges
    • ECOSYSTEM: < 2.23-0ubuntu11.2

    Update to 2.23-0ubuntu11.2

  • glibc Ubuntu:18.04:LTS

    Versions
    • 2.26-0ubuntu2
    • 2.26-0ubuntu2.1
    • 2.27-0ubuntu2
    • 2.27-0ubuntu3
    • 2.27-3ubuntu1
    Affected ranges
    • ECOSYSTEM: < 2.27-3ubuntu1.2

    Update to 2.27-3ubuntu1.2

Original sources

Check your server →