CVE-2018-14041
CVE-2018-14041
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In Bootstrap before 4.1.2, XSS is possible in the data-target property of scrollspy.
CVSS 6.1 · Medium · EPSS 4.3% · Fix available
- Published
- Updated
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
bootstrap npm
- Affected ranges
- SEMVER: ≥ 4.0.0, < 4.1.2
Update to 4.1.2
typo3/cms-core Packagist
- Versions
- v8.7.10
- v8.7.11
- v8.7.12
- v8.7.13
- v8.7.14
- v8.7.15
- v8.7.16
- v8.7.17
- v8.7.18
- v8.7.19
- v8.7.20
- v8.7.21
- v8.7.22
- v8.7.7
- v8.7.8
- v8.7.9
- Affected ranges
- ECOSYSTEM: ≥ 8.0.0, < 8.7.23
Update to 8.7.23
typo3/cms-core Packagist
- Versions
- v9.0.0
- v9.1.0
- v9.2.0
- v9.2.1
- v9.3.0
- v9.3.1
- v9.3.2
- v9.3.3
- v9.4.0
- v9.5.0
- v9.5.1
- v9.5.2
- v9.5.3
- Affected ranges
- ECOSYSTEM: ≥ 9.0.0, < 9.5.4
Update to 9.5.4
typo3/cms Packagist
- Versions
- 8.0.0
- 8.0.1
- 8.1.0
- 8.1.1
- 8.1.2
- 8.2.0
- 8.2.1
- 8.3.0
- 8.3.1
- 8.4.0
- 8.4.1
- 8.5.0
- 8.5.1
- 8.6.0
- 8.6.1
- 8.7.0
- 8.7.1
- 8.7.2
- v8.7.10
- v8.7.11
- v8.7.12
- v8.7.13
- v8.7.14
- v8.7.15
- v8.7.16
- v8.7.17
- v8.7.18
- v8.7.19
- v8.7.20
- v8.7.21
- v8.7.22
- v8.7.3
- v8.7.4
- v8.7.5
- v8.7.6
- v8.7.7
- v8.7.8
- v8.7.9
- Affected ranges
- ECOSYSTEM: ≥ 8.0.0, < 8.7.23
Update to 8.7.23
typo3/cms Packagist
- Versions
- v9.0.0
- v9.1.0
- v9.2.0
- v9.2.1
- v9.3.0
- v9.3.1
- v9.3.2
- v9.3.3
- v9.4.0
- v9.5.0
- v9.5.1
- v9.5.2
- v9.5.3
- Affected ranges
- ECOSYSTEM: ≥ 9.0.0, < 9.5.4
Update to 9.5.4
bootstrap RubyGems
- Versions
- 4.0.0
- 4.1.0
- 4.1.1
- Affected ranges
- ECOSYSTEM: ≥ 4.0.0, < 4.1.2
Update to 4.1.2
twbs/bootstrap Packagist
- Versions
- v4.0.0
- v4.1.0
- v4.1.1
- Affected ranges
- ECOSYSTEM: ≥ 4.0.0, < 4.1.2
Update to 4.1.2
bootstrap NuGet
- Versions
- 4.0.0
- 4.1.0
- 4.1.1
- 4.1.1-contentFiles
- Affected ranges
- ECOSYSTEM: ≥ 4.0.0, < 4.1.2
Update to 4.1.2
bootstrap.sass NuGet
- Versions
- 4.0.0
- 4.1.0
- 4.1.1
- 4.1.1-contentFiles
- Affected ranges
- ECOSYSTEM: ≥ 4.0.0, < 4.1.2
Update to 4.1.2
org.webjars:bootstrap Maven
- Versions
- 4.0.0
- 4.0.0-1
- 4.0.0-2
- 4.1.0
- 4.1.1
- Affected ranges
- ECOSYSTEM: ≥ 4.0.0, < 4.1.2
Update to 4.1.2
Original sources
- https://seclists.org/bugtraq/2019/May/18
- http://seclists.org/fulldisclosure/2019/May/11
- http://seclists.org/fulldisclosure/2019/May/10
- http://seclists.org/fulldisclosure/2019/May/13
- https://access.redhat.com/errata/RHSA-2019:1456
- https://lists.apache.org/thread.html/52e0e6b5df827ee7f1e68f7cc3babe61af3b2160f5d74a85469b7b0e%40%3Cdev.superset.apache.org%3E
- https://lists.apache.org/thread.html/b0656d359c7d40ec9f39c8cc61bca66802ef9a2a12ee199f5b0c1442%40%3Cdev.drill.apache.org%3E
- https://lists.apache.org/thread.html/519eb0fd45642dcecd9ff74cb3e71c20a4753f7d82e2f07864b5108f%40%3Cdev.drill.apache.org%3E
- https://lists.apache.org/thread.html/f9bc3e55f4e28d1dcd1a69aae6d53e609a758e34d2869b4d798e13cc%40%3Cissues.drill.apache.org%3E
- http://packetstormsecurity.com/files/152787/dotCMS-5.1.1-Vulnerable-Dependencies.html
- http://packetstormsecurity.com/files/156743/OctoberCMS-Insecure-Dependencies.html
- https://lists.apache.org/thread.html/r3dc0cac8d856bca02bd6997355d7ff83027dcfc82f8646a29b89b714%40%3Cissues.hbase.apache.org%3E
- https://www.oracle.com/security-alerts/cpuApr2021.html
- https://github.com/twbs/bootstrap/pull/26630
- https://github.com/twbs/bootstrap/issues/26423
- https://blog.getbootstrap.com/2018/07/12/bootstrap-4-1-2/
- https://github.com/twbs/bootstrap/issues/26627
- https://nvd.nist.gov/vuln/detail/CVE-2018-14041