p PatchFirst

CVE-2018-14624

CVE-2018-14624

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A vulnerability was discovered in 389-ds-base through versions 1.3.7.10, 1.3.8.8 and 1.4.0.16. The lock controlling the error log was not correctly used when re-opening the log file in log__error_emergency(). An attacker could send a flood of modifications to a very large DN, which would cause slapd to crash.

CVSS 7.5 · High · EPSS 2.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • 389-ds-base

    Versions
    • ≥ unspecified, ≤ 1.4.0.16: Affected (custom)
    • ≥ unspecified, ≤ 1.3.8.8: Affected (custom)
    • ≥ unspecified, ≤ 1.3.7.10: Affected (custom)

    No fix published

  • 389-ds-base Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.4.0.18-1

    Update to 1.4.0.18-1

  • 389-ds-base Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.4.0.18-1

    Update to 1.4.0.18-1

  • 389-ds-base Ubuntu:Pro:16.04:LTS

    Versions
    • 1.3.3.12-1build1
    • 1.3.3.13-1
    • 1.3.4.5-2
    • 1.3.4.8-1
    • 1.3.4.8-3
    • 1.3.4.8-3ubuntu1
    • 1.3.4.8-4
    • 1.3.4.9-1
    • 1.3.4.9-1ubuntu0.1~esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • 389-ds-base Ubuntu:Pro:18.04:LTS

    Versions
    • 1.3.7.5-1
    • 1.3.7.5-1build1
    • 1.3.7.5-1build2
    • 1.3.7.9-1
    • 1.3.7.10-1
    • 1.3.7.10-1ubuntu1
    • 1.3.7.10-1ubuntu1+esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • 389-ds-base Ubuntu:26.04:LTS

    Versions
    • 3.1.2+dfsg1-1
    • 3.1.2+vendor1-2
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →