CVE-2018-16151
CVE-2018-16151
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In verify_emsa_pkcs1_signature() in gmp_rsa_public_key.c in the gmp plugin in strongSwan 4.x and 5.x before 5.7.0, the RSA implementation based on GMP does not reject excess data after the encoded algorithm OID during PKCS#1 v1.5 signature verification. Similar to the flaw in the same version of strongSwan regarding digestAlgorithm.parameters, a remote attacker can forge signatures when small public exponents are being used, which could lead to impersonation when only an RSA signature is used for IKEv2 authentication.
CVSS 7.5 · High · EPSS 1.9% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
strongswan Debian:12
- Affected ranges
- ECOSYSTEM: < 5.7.0-1
Update to 5.7.0-1
strongswan Debian:13
- Affected ranges
- ECOSYSTEM: < 5.7.0-1
Update to 5.7.0-1
strongswan Debian:14
- Affected ranges
- ECOSYSTEM: < 5.7.0-1
Update to 5.7.0-1
strongswan Ubuntu:14.04:LTS
- Versions
- 4.6.4-9
- 5.1.0-2
- 5.1.0-3
- 5.1.1-0ubuntu1
- 5.1.1-0ubuntu2
- 5.1.1-0ubuntu3
- 5.1.1-0ubuntu4
- 5.1.1-0ubuntu5
- 5.1.1-0ubuntu7
- 5.1.1-0ubuntu14
- 5.1.1-0ubuntu17
- 5.1.2~dr3+git20130120-0ubuntu2
- 5.1.2~dr3+git20130120-0ubuntu3
- 5.1.2~rc1-0ubuntu3
- 5.1.2~rc1-0ubuntu4
- 5.1.2~rc2-0ubuntu2
- 5.1.2-0ubuntu1
- 5.1.2-0ubuntu2
- 5.1.2-0ubuntu2.2
- 5.1.2-0ubuntu2.3
- 5.1.2-0ubuntu2.4
- 5.1.2-0ubuntu2.5
- 5.1.2-0ubuntu2.6
- 5.1.2-0ubuntu2.7
- 5.1.2-0ubuntu2.8
- Affected ranges
- ECOSYSTEM: < 5.1.2-0ubuntu2.10
Update to 5.1.2-0ubuntu2.10
strongswan Ubuntu:16.04:LTS
- Versions
- 5.1.2-0ubuntu6
- 5.1.2-0ubuntu7
- 5.1.2-0ubuntu8
- 5.3.5-1ubuntu1
- 5.3.5-1ubuntu2
- 5.3.5-1ubuntu3
- 5.3.5-1ubuntu3.1
- 5.3.5-1ubuntu3.2
- 5.3.5-1ubuntu3.3
- 5.3.5-1ubuntu3.4
- 5.3.5-1ubuntu3.5
- Affected ranges
- ECOSYSTEM: < 5.3.5-1ubuntu3.7
Update to 5.3.5-1ubuntu3.7
strongswan Ubuntu:18.04:LTS
- Versions
- 5.5.1-4ubuntu2
- 5.5.1-4ubuntu3
- 5.6.1-2ubuntu1
- 5.6.1-2ubuntu2
- 5.6.1-2ubuntu3
- 5.6.1-2ubuntu4
- 5.6.2-1ubuntu2
- Affected ranges
- ECOSYSTEM: < 5.6.2-1ubuntu2.2
Update to 5.6.2-1ubuntu2.2
Original sources
- https://www.debian.org/security/2018/dsa-4305
- https://security.gentoo.org/glsa/201811-16
- https://www.strongswan.org/blog/2018/09/24/strongswan-vulnerability-%28cve-2018-16151%2C-cve-2018-16152%29.html
- https://lists.debian.org/debian-lts-announce/2018/09/msg00032.html
- https://usn.ubuntu.com/3771-1/
- http://lists.opensuse.org/opensuse-security-announce/2019-11/msg00077.html
- http://lists.opensuse.org/opensuse-security-announce/2019-12/msg00001.html
- http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00047.html
- https://nvd.nist.gov/vuln/detail/CVE-2018-16151