p PatchFirst

PatchFirst · Latest vulnerabilities

strongswan vulnerabilities

Vulnerabilities published for strongswan in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 9

  1. CVE-2022-40617

    High · CVSS 7.5EPSS 1.98%Fix available

    CVE-2022-40617

    strongSwan before 5.9.8 allows remote attackers to cause a denial of service in the revocation plugin by sending a crafted end-entity (and intermediate CA) certificate that contains a CRL/OCSP URL that points to a server (under the attacker's control) that doesn't properly respond but (for example) just does nothing after the initial TCP handshake, or sends an excessive amount of application data.

    • Update to 5.6.2-1ubuntu2.9
    Published Updated
  2. CVE-2021-45079

    Critical · CVSS 9.1EPSS 2.78%Fix available

    CVE-2021-45079

    In strongSwan before 5.9.5, a malicious responder can send an EAP-Success message too early without actually authenticating the client and (in the case of EAP methods with mutual authentication and EAP-only authentication for IKEv2) even without server authentication.

    • Update to 5.6.2-1ubuntu2.8
    Published Updated
  3. CVE-2021-41991

    High · CVSS 7.5EPSS 5.3%Fix available

    CVE-2021-41991

    The in-memory certificate cache in strongSwan before 5.9.4 has a remote integer overflow upon receiving many requests with different certificates to fill the cache and later trigger the replacement of cache entries. The code attempts to select a less-often-used cache entry by means of a random number generator, but this is not done correctly. Remote code execution might be a slight possibility.

    • Update to 5.6.2-1ubuntu2.7
    Published Updated
  4. CVE-2018-16152

    High · CVSS 7.5EPSS 1.89%Fix available

    CVE-2018-16152

    In verify_emsa_pkcs1_signature() in gmp_rsa_public_key.c in the gmp plugin in strongSwan 4.x and 5.x before 5.7.0, the RSA implementation based on GMP does not reject excess data in the digestAlgorithm.parameters field during PKCS#1 v1.5 signature verification. Consequently, a remote attacker can forge signatures when small public exponents are being used, which could lead to impersonation when only an RSA signature is used for IKEv2 authentication. This is a variant of CVE-2006-4790 and CVE-2014-1568.

    • Update to 5.6.2-1ubuntu2.2
    Published Updated
  5. CVE-2018-16151

    High · CVSS 7.5EPSS 1.89%Fix available

    CVE-2018-16151

    In verify_emsa_pkcs1_signature() in gmp_rsa_public_key.c in the gmp plugin in strongSwan 4.x and 5.x before 5.7.0, the RSA implementation based on GMP does not reject excess data after the encoded algorithm OID during PKCS#1 v1.5 signature verification. Similar to the flaw in the same version of strongSwan regarding digestAlgorithm.parameters, a remote attacker can forge signatures when small public exponents are being used, which could lead to impersonation when only an RSA signature is used for IKEv2 authentication.

    • Update to 5.6.2-1ubuntu2.2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →