CVE-2018-16842
CVE-2018-16842
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Curl versions 7.14.1 through 7.61.1 are vulnerable to a heap-based buffer over-read in the tool_msgs.c:voutf() function that may result in information exposure and denial of service.
CVSS 4.4 · Medium · EPSS 2.1% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
curl:
- Versions
- from 7.14.1 to 7.61.1: Affected
No fix published
curl Debian:12
- Affected ranges
- ECOSYSTEM: < 7.62.0-1
Update to 7.62.0-1
curl Debian:13
- Affected ranges
- ECOSYSTEM: < 7.62.0-1
Update to 7.62.0-1
curl Debian:14
- Affected ranges
- ECOSYSTEM: < 7.62.0-1
Update to 7.62.0-1
curl Ubuntu:14.04:LTS
- Versions
- 7.32.0-1ubuntu1
- 7.33.0-1ubuntu1
- 7.34.0-1ubuntu1
- 7.35.0-1ubuntu1
- 7.35.0-1ubuntu2
- 7.35.0-1ubuntu2.1
- 7.35.0-1ubuntu2.2
- 7.35.0-1ubuntu2.3
- 7.35.0-1ubuntu2.5
- 7.35.0-1ubuntu2.6
- 7.35.0-1ubuntu2.7
- 7.35.0-1ubuntu2.8
- 7.35.0-1ubuntu2.9
- 7.35.0-1ubuntu2.10
- 7.35.0-1ubuntu2.11
- 7.35.0-1ubuntu2.12
- 7.35.0-1ubuntu2.13
- 7.35.0-1ubuntu2.14
- 7.35.0-1ubuntu2.15
- 7.35.0-1ubuntu2.16
- 7.35.0-1ubuntu2.17
- Affected ranges
- ECOSYSTEM: < 7.35.0-1ubuntu2.19
Update to 7.35.0-1ubuntu2.19
curl Ubuntu:16.04:LTS
- Versions
- 7.43.0-1ubuntu2
- 7.45.0-1ubuntu1
- 7.46.0-1ubuntu1
- 7.47.0-1ubuntu1
- 7.47.0-1ubuntu2
- 7.47.0-1ubuntu2.1
- 7.47.0-1ubuntu2.2
- 7.47.0-1ubuntu2.3
- 7.47.0-1ubuntu2.4
- 7.47.0-1ubuntu2.5
- 7.47.0-1ubuntu2.6
- 7.47.0-1ubuntu2.7
- 7.47.0-1ubuntu2.8
- 7.47.0-1ubuntu2.9
- Affected ranges
- ECOSYSTEM: < 7.47.0-1ubuntu2.11
Update to 7.47.0-1ubuntu2.11
curl Ubuntu:18.04:LTS
- Versions
- 7.55.1-1ubuntu2
- 7.55.1-1ubuntu2.1
- 7.57.0-1ubuntu1
- 7.58.0-2ubuntu1
- 7.58.0-2ubuntu2
- 7.58.0-2ubuntu3
- 7.58.0-2ubuntu3.1
- 7.58.0-2ubuntu3.2
- 7.58.0-2ubuntu3.3
- Affected ranges
- ECOSYSTEM: < 7.58.0-2ubuntu3.5
Update to 7.58.0-2ubuntu3.5
Original sources
- https://security.gentoo.org/glsa/201903-03
- https://www.debian.org/security/2018/dsa-4331
- https://lists.debian.org/debian-lts-announce/2018/11/msg00005.html
- https://curl.haxx.se/docs/CVE-2018-16842.html
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-16842
- http://www.securitytracker.com/id/1042014
- https://github.com/curl/curl/commit/d530e92f59ae9bb2d47066c3c460b25d2ffeb211
- https://usn.ubuntu.com/3805-2/
- https://usn.ubuntu.com/3805-1/
- https://access.redhat.com/errata/RHSA-2019:2181
- https://www.oracle.com/technetwork/security-advisory/cpuoct2019-5072832.html
- https://nvd.nist.gov/vuln/detail/CVE-2018-16842