p PatchFirst

CVE-2018-16890

CVE-2018-16890

This page contains facts from public vulnerability sources. Check the original advisory before updating.

libcurl versions from 7.36.0 to before 7.64.0 is vulnerable to a heap buffer out-of-bounds read. The function handling incoming NTLM type-2 messages (`lib/vauth/ntlm.c:ntlm_decode_type2_target`) does not validate incoming data correctly and is subject to an integer overflow vulnerability. Using that overflow, a malicious or broken NTLM server could trick libcurl to accept a bad length + offset combination that would lead to a buffer read out-of-bounds.

CVSS 5.4 · Medium · EPSS 5.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • curl

    Versions
    • 7.64.0: Affected

    No fix published

  • curl Debian:12

    Affected ranges
    • ECOSYSTEM: < 7.64.0-1

    Update to 7.64.0-1

  • curl Debian:13

    Affected ranges
    • ECOSYSTEM: < 7.64.0-1

    Update to 7.64.0-1

  • curl Debian:14

    Affected ranges
    • ECOSYSTEM: < 7.64.0-1

    Update to 7.64.0-1

  • curl Ubuntu:16.04:LTS

    Versions
    • 7.43.0-1ubuntu2
    • 7.45.0-1ubuntu1
    • 7.46.0-1ubuntu1
    • 7.47.0-1ubuntu1
    • 7.47.0-1ubuntu2
    • 7.47.0-1ubuntu2.1
    • 7.47.0-1ubuntu2.2
    • 7.47.0-1ubuntu2.3
    • 7.47.0-1ubuntu2.4
    • 7.47.0-1ubuntu2.5
    • 7.47.0-1ubuntu2.6
    • 7.47.0-1ubuntu2.7
    • 7.47.0-1ubuntu2.8
    • 7.47.0-1ubuntu2.9
    • 7.47.0-1ubuntu2.11
    Affected ranges
    • ECOSYSTEM: < 7.47.0-1ubuntu2.12

    Update to 7.47.0-1ubuntu2.12

  • curl Ubuntu:18.04:LTS

    Versions
    • 7.55.1-1ubuntu2
    • 7.55.1-1ubuntu2.1
    • 7.57.0-1ubuntu1
    • 7.58.0-2ubuntu1
    • 7.58.0-2ubuntu2
    • 7.58.0-2ubuntu3
    • 7.58.0-2ubuntu3.1
    • 7.58.0-2ubuntu3.2
    • 7.58.0-2ubuntu3.3
    • 7.58.0-2ubuntu3.5
    Affected ranges
    • ECOSYSTEM: < 7.58.0-2ubuntu3.6

    Update to 7.58.0-2ubuntu3.6

Original sources

Check your server →