CVE-2018-17540
CVE-2018-17540
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The gmp plugin in strongSwan before 5.7.1 has a Buffer Overflow via a crafted certificate.
CVSS 7.5 · High · EPSS 3.5% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
strongswan Debian:12
- Affected ranges
- ECOSYSTEM: < 5.7.1-1
Update to 5.7.1-1
strongswan Debian:13
- Affected ranges
- ECOSYSTEM: < 5.7.1-1
Update to 5.7.1-1
strongswan Debian:14
- Affected ranges
- ECOSYSTEM: < 5.7.1-1
Update to 5.7.1-1
strongswan Ubuntu:14.04:LTS
- Versions
- 4.6.4-9
- 5.1.0-2
- 5.1.0-3
- 5.1.1-0ubuntu1
- 5.1.1-0ubuntu2
- 5.1.1-0ubuntu3
- 5.1.1-0ubuntu4
- 5.1.1-0ubuntu5
- 5.1.1-0ubuntu7
- 5.1.1-0ubuntu14
- 5.1.1-0ubuntu17
- 5.1.2~dr3+git20130120-0ubuntu2
- 5.1.2~dr3+git20130120-0ubuntu3
- 5.1.2~rc1-0ubuntu3
- 5.1.2~rc1-0ubuntu4
- 5.1.2~rc2-0ubuntu2
- 5.1.2-0ubuntu1
- 5.1.2-0ubuntu2
- 5.1.2-0ubuntu2.2
- 5.1.2-0ubuntu2.3
- 5.1.2-0ubuntu2.4
- 5.1.2-0ubuntu2.5
- 5.1.2-0ubuntu2.6
- 5.1.2-0ubuntu2.7
- 5.1.2-0ubuntu2.8
- 5.1.2-0ubuntu2.10
- Affected ranges
- ECOSYSTEM: < 5.1.2-0ubuntu2.11
Update to 5.1.2-0ubuntu2.11
strongswan Ubuntu:16.04:LTS
- Versions
- 5.1.2-0ubuntu6
- 5.1.2-0ubuntu7
- 5.1.2-0ubuntu8
- 5.3.5-1ubuntu1
- 5.3.5-1ubuntu2
- 5.3.5-1ubuntu3
- 5.3.5-1ubuntu3.1
- 5.3.5-1ubuntu3.2
- 5.3.5-1ubuntu3.3
- 5.3.5-1ubuntu3.4
- 5.3.5-1ubuntu3.5
- 5.3.5-1ubuntu3.7
- Affected ranges
- ECOSYSTEM: < 5.3.5-1ubuntu3.8
Update to 5.3.5-1ubuntu3.8
strongswan Ubuntu:18.04:LTS
- Versions
- 5.5.1-4ubuntu2
- 5.5.1-4ubuntu3
- 5.6.1-2ubuntu1
- 5.6.1-2ubuntu2
- 5.6.1-2ubuntu3
- 5.6.1-2ubuntu4
- 5.6.2-1ubuntu2
- 5.6.2-1ubuntu2.2
- Affected ranges
- ECOSYSTEM: < 5.6.2-1ubuntu2.3
Update to 5.6.2-1ubuntu2.3
Original sources
- https://www.debian.org/security/2018/dsa-4309
- https://lists.debian.org/debian-lts-announce/2018/10/msg00001.html
- https://www.strongswan.org/blog/2018/10/01/strongswan-vulnerability-%28cve-2018-17540%29.html
- https://usn.ubuntu.com/3774-1/
- https://download.strongswan.org/security/CVE-2018-17540/
- https://security.gentoo.org/glsa/201811-16
- http://lists.opensuse.org/opensuse-security-announce/2019-11/msg00077.html
- http://lists.opensuse.org/opensuse-security-announce/2019-12/msg00001.html
- http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00047.html
- https://nvd.nist.gov/vuln/detail/CVE-2018-17540