CVE-2018-20022
CVE-2018-20022
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This page shows selected source facts. See the linked advisories for the complete description and affected versions.
LibVNC before 2f5b2ad1c6c99b1ac6482c95844a84d66bb52838 contains multiple weaknesses CWE-665: Improper Initialization vulnerability in VNC client code that allows attacker to read stack memory and can be abuse for information disclosure. Combined with another vulnerability, it can be used to leak stack memory layout and in bypassing ASLR
CVSS 7.5 · High · EPSS 2.9% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
libvnc
- Versions
- commit 2f5b2ad1c6c99b1ac6482c95844a84d66bb52838: Affected
No fix published
libvncserver Debian:12
- Affected ranges
- ECOSYSTEM: < 0.9.11+dfsg-1.2
Update to 0.9.11+dfsg-1.2
libvncserver Debian:13
- Affected ranges
- ECOSYSTEM: < 0.9.11+dfsg-1.2
Update to 0.9.11+dfsg-1.2
libvncserver Debian:14
- Affected ranges
- ECOSYSTEM: < 0.9.11+dfsg-1.2
Update to 0.9.11+dfsg-1.2
ssvnc Debian:12
- Affected ranges
- ECOSYSTEM: < 1.0.29-5
Update to 1.0.29-5
ssvnc Debian:13
- Affected ranges
- ECOSYSTEM: < 1.0.29-5
Update to 1.0.29-5
ssvnc Debian:14
- Affected ranges
- ECOSYSTEM: < 1.0.29-5
Update to 1.0.29-5
tightvnc Debian:12
- Affected ranges
- ECOSYSTEM: < 1:1.3.9-9.1
Update to 1:1.3.9-9.1
tightvnc Debian:13
- Affected ranges
- ECOSYSTEM: < 1:1.3.9-9.1
Update to 1:1.3.9-9.1
tightvnc Debian:14
- Affected ranges
- ECOSYSTEM: < 1:1.3.9-9.1
Update to 1:1.3.9-9.1
veyon Debian:12
- Affected ranges
- ECOSYSTEM: < 4.1.4+repack1-1
Update to 4.1.4+repack1-1
veyon Debian:13
- Affected ranges
- ECOSYSTEM: < 4.1.4+repack1-1
Update to 4.1.4+repack1-1
libvncserver Ubuntu:14.04:LTS
- Versions
- 0.9.9+dfsg-1
- 0.9.9+dfsg-1ubuntu1
- 0.9.9+dfsg-1ubuntu1.1
- 0.9.9+dfsg-1ubuntu1.2
- 0.9.9+dfsg-1ubuntu1.3
- Affected ranges
- ECOSYSTEM: < 0.9.9+dfsg-1ubuntu1.4
Update to 0.9.9+dfsg-1ubuntu1.4
tightvnc Ubuntu:Pro:14.04:LTS
- Versions
- 1.3.9-6.4
- 1.3.9-6.4ubuntu1
- Affected ranges
- ECOSYSTEM: < 1.3.9-6.5+deb8u1build0.14.04.1~esm1
Update to 1.3.9-6.5+deb8u1build0.14.04.1~esm1
italc Ubuntu:16.04:LTS
- Versions
- 1:2.0.2+dfsg1-3
- 1:2.0.2+dfsg1-4
- Affected ranges
- ECOSYSTEM: < 1:2.0.2+dfsg1-4ubuntu0.1
Update to 1:2.0.2+dfsg1-4ubuntu0.1
libvncserver Ubuntu:16.04:LTS
- Versions
- 0.9.10+dfsg-3
- 0.9.10+dfsg-3build1
- 0.9.10+dfsg-3ubuntu0.16.04.1
- 0.9.10+dfsg-3ubuntu0.16.04.2
- Affected ranges
- ECOSYSTEM: < 0.9.10+dfsg-3ubuntu0.16.04.3
Update to 0.9.10+dfsg-3ubuntu0.16.04.3
ssvnc Ubuntu:16.04:LTS
- Versions
- 1.0.29-2build1
- Affected ranges
- ECOSYSTEM: < 1.0.29-2+deb8u1build0.16.04.1
Update to 1.0.29-2+deb8u1build0.16.04.1
tightvnc Ubuntu:16.04:LTS
- Versions
- 1.3.10-0ubuntu2
- 1.3.10-0ubuntu3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
italc Ubuntu:18.04:LTS
- Versions
- 1:3.0.3+dfsg1-1
- 1:3.0.3+dfsg1-2
- 1:3.0.3+dfsg1-2build1
- 1:3.0.3+dfsg1-2ubuntu1
- 1:3.0.3+dfsg1-3
- Affected ranges
- ECOSYSTEM: < 1:3.0.3+dfsg1-3ubuntu0.1
Update to 1:3.0.3+dfsg1-3ubuntu0.1
libvncserver Ubuntu:18.04:LTS
- Versions
- 0.9.11+dfsg-1
- 0.9.11+dfsg-1ubuntu1
- Affected ranges
- ECOSYSTEM: < 0.9.11+dfsg-1ubuntu1.1
Update to 0.9.11+dfsg-1ubuntu1.1
ssvnc Ubuntu:18.04:LTS
- Versions
- 1.0.29-3
- 1.0.29-3build1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
tightvnc Ubuntu:18.04:LTS
- Versions
- 1.3.10-0ubuntu3
- 1.3.10-0ubuntu4
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
tightvnc Ubuntu:20.04:LTS
- Versions
- 1.3.10-0ubuntu5
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
tightvnc Ubuntu:22.04:LTS
- Versions
- 1:1.3.10-3
- 1:1.3.10-5
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://www.debian.org/security/2019/dsa-4383
- https://lists.debian.org/debian-lts-announce/2018/12/msg00017.html
- https://ics-cert.kaspersky.com/advisories/klcert-advisories/2018/12/19/klcert-18-032-libvnc-multiple-memory-leaks/
- https://usn.ubuntu.com/3877-1/
- https://security.gentoo.org/glsa/201908-05
- https://lists.debian.org/debian-lts-announce/2019/10/msg00042.html
- https://lists.debian.org/debian-lts-announce/2019/11/msg00033.html
- https://lists.debian.org/debian-lts-announce/2019/12/msg00028.html
- https://security.gentoo.org/glsa/202006-06
- https://usn.ubuntu.com/4547-1/
- https://usn.ubuntu.com/4547-2/
- https://usn.ubuntu.com/4587-1/
- https://nvd.nist.gov/vuln/detail/CVE-2018-20022