p PatchFirst

PatchFirst · Latest vulnerabilities

italc vulnerabilities

Vulnerabilities published for italc in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 18

  1. CVE-2026-50538

    High · CVSS 8.8EPSS 0.4%No fix published

    libvncclient Tight decoder has an attacker-controlled heap out-of-bounds write

    LibVNCClient is a library for easy implementation of a VNC client. In versions 0.9.12 through 0.9.15, a malicious (or man-in-the-middle) VNC server can force a connecting `libvncclient` to write attacker-controlled data past the end of its framebuffer. This is an out-of-bounds heap write with attacker-controlled length, contents, and offset. It needs no authentication (the attacker is the server), works in a default build with default settings, and fires from a single `FramebufferUpdate` the moment the victim connects. It crashes any client unconditionally (denial of service); we also demonstrated it overwriting an application callback pointe

    Published Updated
  2. CVE-2026-44988

    High · CVSS 8.8EPSS 0.24%No fix published

    LibVNCClient Tight Gradient decoding allows malicious server-triggered heap/stack OOB writes

    LibVNCClient is a library for easy implementation of a VNC client. In 0.9.15 and earlier, LibVNCClient's Tight encoding decoder uses fixed-size 2048-pixel scratch buffers for the Gradient filter, but it does not reject Tight rectangles whose width is larger than 2048 pixels. A malicious VNC server can send a crafted FramebufferUpdate rectangle using Tight encoding with NoZlib | ExplicitFilter and the Gradient filter. When a LibVNCClient-based client connects, the client processes the server-controlled rectangle width and writes beyond fixed-size Gradient buffers. This vulnerability is fixed with commit 5b270544b85233668b98161323297d418a8f5fd1

    Published Updated
  3. CVE-2026-32854

    Medium · CVSS 6.3EPSS 5.42%No fix published

    LibVNCServer httpd proxy NULL Pointer Dereference

    LibVNCServer versions 0.9.15 and prior (fixed in commit dc78dee) contain null pointer dereference vulnerabilities in the HTTP proxy handlers within httpProcessInput() in httpd.c that allow remote attackers to cause a denial of service by sending specially crafted HTTP requests. Attackers can exploit missing validation of strchr() return values in the CONNECT and GET proxy handling paths to trigger null pointer dereferences and crash the server when httpd and proxy features are enabled.

    Published Updated
  4. CVE-2026-32853

    Medium · CVSS 6.9EPSS 0.45%No fix published

    LibVNCServer UltraZip Encoding Heap Out-of-bounds Read

    LibVNCServer versions 0.9.15 and prior (fixed in commit 009008e) contain a heap out-of-bounds read vulnerability in the UltraZip encoding handler that allows a malicious VNC server to cause information disclosure or application crash. Attackers can exploit improper bounds checking in the HandleUltraZipBPP() function by manipulating subrectangle header counts to read beyond the allocated heap buffer.

    Published Updated
  5. CVE-2019-15681

    High · CVSS 7.5EPSS 2.91%Fix available

    CVE-2019-15681

    LibVNC commit before d01e1bb4246323ba6fcee3b82ef1faa9b1dac82a contains a memory leak (CWE-655) in VNC server code, which allow an attacker to read stack memory and can be abused for information disclosure. Combined with another vulnerability, it can be used to leak stack memory and bypass ASLR. This attack appear to be exploitable via network connectivity. These vulnerabilities have been fixed in commit d01e1bb4246323ba6fcee3b82ef1faa9b1dac82a.

    • Update to 1:3.0.3+dfsg1-3ubuntu0.1
    Published Updated
  6. CVE-2018-20023

    High · CVSS 7.5EPSS 2.5%Fix available

    CVE-2018-20023

    LibVNC before 8b06f835e259652b0ff026898014fc7297ade858 contains CWE-665: Improper Initialization vulnerability in VNC Repeater client code that allows attacker to read stack memory and can be abuse for information disclosure. Combined with another vulnerability, it can be used to leak stack memory layout and in bypassing ASLR

    • Update to 1:3.0.3+dfsg1-3ubuntu0.1
    Published Updated
  7. CVE-2018-20022

    High · CVSS 7.5EPSS 2.94%Fix available

    CVE-2018-20022

    LibVNC before 2f5b2ad1c6c99b1ac6482c95844a84d66bb52838 contains multiple weaknesses CWE-665: Improper Initialization vulnerability in VNC client code that allows attacker to read stack memory and can be abuse for information disclosure. Combined with another vulnerability, it can be used to leak stack memory layout and in bypassing ASLR

    • Update to 1:3.0.3+dfsg1-3ubuntu0.1
    Published Updated
  8. CVE-2018-7225

    Critical · CVSS 9.8EPSS 6.11%Fix available

    CVE-2018-7225

    An issue was discovered in LibVNCServer through 0.9.11. rfbProcessClientNormalMessage() in rfbserver.c does not sanitize msg.cct.length, leading to access to uninitialized and potentially sensitive data or possibly unspecified other impact (e.g., an integer overflow) via specially crafted VNC packets.

    • Update to 1:3.0.3+dfsg1-3ubuntu0.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →