CVE-2018-20023
CVE-2018-20023
This page contains facts from public vulnerability sources. Check the original advisory before updating.
LibVNC before 8b06f835e259652b0ff026898014fc7297ade858 contains CWE-665: Improper Initialization vulnerability in VNC Repeater client code that allows attacker to read stack memory and can be abuse for information disclosure. Combined with another vulnerability, it can be used to leak stack memory layout and in bypassing ASLR
CVSS 7.5 · High · EPSS 2.5% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
libvnc
- Versions
- commit 8b06f835e259652b0ff026898014fc7297ade858: Affected
No fix published
libvncserver Debian:12
- Affected ranges
- ECOSYSTEM: < 0.9.11+dfsg-1.2
Update to 0.9.11+dfsg-1.2
libvncserver Debian:13
- Affected ranges
- ECOSYSTEM: < 0.9.11+dfsg-1.2
Update to 0.9.11+dfsg-1.2
libvncserver Debian:14
- Affected ranges
- ECOSYSTEM: < 0.9.11+dfsg-1.2
Update to 0.9.11+dfsg-1.2
veyon Debian:12
- Affected ranges
- ECOSYSTEM: < 4.1.4+repack1-1
Update to 4.1.4+repack1-1
veyon Debian:13
- Affected ranges
- ECOSYSTEM: < 4.1.4+repack1-1
Update to 4.1.4+repack1-1
libvncserver Ubuntu:14.04:LTS
- Versions
- 0.9.9+dfsg-1
- 0.9.9+dfsg-1ubuntu1
- 0.9.9+dfsg-1ubuntu1.1
- 0.9.9+dfsg-1ubuntu1.2
- 0.9.9+dfsg-1ubuntu1.3
- Affected ranges
- ECOSYSTEM: < 0.9.9+dfsg-1ubuntu1.4
Update to 0.9.9+dfsg-1ubuntu1.4
italc Ubuntu:16.04:LTS
- Versions
- 1:2.0.2+dfsg1-3
- 1:2.0.2+dfsg1-4
- Affected ranges
- ECOSYSTEM: < 1:2.0.2+dfsg1-4ubuntu0.1
Update to 1:2.0.2+dfsg1-4ubuntu0.1
libvncserver Ubuntu:16.04:LTS
- Versions
- 0.9.10+dfsg-3
- 0.9.10+dfsg-3build1
- 0.9.10+dfsg-3ubuntu0.16.04.1
- 0.9.10+dfsg-3ubuntu0.16.04.2
- Affected ranges
- ECOSYSTEM: < 0.9.10+dfsg-3ubuntu0.16.04.3
Update to 0.9.10+dfsg-3ubuntu0.16.04.3
italc Ubuntu:18.04:LTS
- Versions
- 1:3.0.3+dfsg1-1
- 1:3.0.3+dfsg1-2
- 1:3.0.3+dfsg1-2build1
- 1:3.0.3+dfsg1-2ubuntu1
- 1:3.0.3+dfsg1-3
- Affected ranges
- ECOSYSTEM: < 1:3.0.3+dfsg1-3ubuntu0.1
Update to 1:3.0.3+dfsg1-3ubuntu0.1
libvncserver Ubuntu:18.04:LTS
- Versions
- 0.9.11+dfsg-1
- 0.9.11+dfsg-1ubuntu1
- Affected ranges
- ECOSYSTEM: < 0.9.11+dfsg-1ubuntu1.1
Update to 0.9.11+dfsg-1ubuntu1.1
Original sources
- https://ics-cert.kaspersky.com/advisories/klcert-advisories/2018/12/19/klcert-18-033-libvnc-memory-leak/
- https://www.debian.org/security/2019/dsa-4383
- https://lists.debian.org/debian-lts-announce/2018/12/msg00017.html
- https://usn.ubuntu.com/3877-1/
- https://security.gentoo.org/glsa/201908-05
- https://lists.debian.org/debian-lts-announce/2019/10/msg00042.html
- https://usn.ubuntu.com/4547-1/
- https://usn.ubuntu.com/4587-1/
- https://nvd.nist.gov/vuln/detail/CVE-2018-20023