CVE-2018-3721
CVE-2018-3721
This page contains facts from public vulnerability sources. Check the original advisory before updating.
lodash node module before 4.17.5 suffers from a Modification of Assumed-Immutable Data (MAID) vulnerability via defaultsDeep, merge, and mergeWith functions, which allows a malicious user to modify the prototype of "Object" via __proto__, causing the addition or modification of an existing property that will exist on all objects.
CVSS 6.5 · Medium · EPSS 2.3% · Fix available
- Published
- Updated
Affected products and versions
lodash node module
- Versions
- Versions before 4.17.5: Affected
No fix published
node-lodash Debian:12
- Affected ranges
- ECOSYSTEM: < 4.17.11+dfsg-1
Update to 4.17.11+dfsg-1
node-lodash Debian:13
- Affected ranges
- ECOSYSTEM: < 4.17.11+dfsg-1
Update to 4.17.11+dfsg-1
node-lodash Debian:14
- Affected ranges
- ECOSYSTEM: < 4.17.11+dfsg-1
Update to 4.17.11+dfsg-1
lodash npm
- Affected ranges
- SEMVER: < 4.17.5
Update to 4.17.5
lodash-rails RubyGems
- Versions
- 0.10.0
- 0.7.0
- 0.8.1
- 0.8.2
- 0.9.0
- 0.9.1
- 0.9.2
- 1.0.0.rc.1
- 1.0.0.rc.2
- 1.0.0.rc.3
- 1.0.1
- 1.1.0
- 1.1.1
- 1.2.0
- 1.2.1
- 1.3.1
- 2.0.0
- 2.1.0
- 2.2.0
- 2.2.1
- 2.3.0
- 2.4.0
- 2.4.1
- 3.1.0
- 3.10.0
- 3.10.1
- 3.2.0
- 3.3.0
- 3.3.1
- 3.3.1.1
- 3.4.0
- 3.5.0
- 3.6.0
- 3.7.0
- 3.9.3
- 4.0.0
- 4.11.2
- 4.12.0
- 4.13.1
- 4.14.1
- 4.15.0
- 4.16.1
- 4.16.3
- 4.16.4
- 4.16.6
- 4.17.2
- 4.17.4
- 4.3.0
- 4.5.1
- 4.6.1
- Affected ranges
- ECOSYSTEM: < 4.17.5
Update to 4.17.5
node-lodash Ubuntu:Pro:16.04:LTS
- Versions
- 2.4.1+dfsg-3
- 2.4.1+dfsg-3ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-lodash Ubuntu:Pro:18.04:LTS
- Versions
- 4.17.4+dfsg-1
- 4.17.4+dfsg-1ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published