CVE-2018-6758
CVE-2018-6758
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The uwsgi_expand_path function in core/utils.c in Unbit uWSGI through 2.0.15 has a stack-based buffer overflow via a large directory length.
CVSS 9.8 · Critical · EPSS 2.0% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
uwsgi Debian:12
- Affected ranges
- ECOSYSTEM: < 2.0.15-10.2
Update to 2.0.15-10.2
uwsgi Debian:13
- Affected ranges
- ECOSYSTEM: < 2.0.15-10.2
Update to 2.0.15-10.2
uwsgi Debian:14
- Affected ranges
- ECOSYSTEM: < 2.0.15-10.2
Update to 2.0.15-10.2
uwsgi Ubuntu:14.04:LTS
- Versions
- 1.9.13-4build1
- 1.9.17.1-5
- 1.9.17.1-5build2
- 1.9.17.1-5build4
- 1.9.17.1-5build5
- Affected ranges
- ECOSYSTEM: < 1.9.17.1-5ubuntu0.1
Update to 1.9.17.1-5ubuntu0.1
uwsgi Ubuntu:16.04:LTS
- Versions
- 2.0.7-1ubuntu5
- 2.0.7-1ubuntu6
- 2.0.11.2-6ubuntu1
- 2.0.11.2-6ubuntu2
- 2.0.12-4ubuntu2
- 2.0.12-5ubuntu1
- 2.0.12-5ubuntu2
- 2.0.12-5ubuntu3
- 2.0.12-5ubuntu3.1
- Affected ranges
- ECOSYSTEM: < 2.0.12-5ubuntu3.2
Update to 2.0.12-5ubuntu3.2