CVE-2018-7490
uWSGI before 2.0.17 mishandles a DOCUMENT_ROOT check during use of the --php-docroot option, allowing directory traversal.
- Update to 1.9.17.1-5ubuntu0.1
Published Updated
PatchFirst · Latest vulnerabilities
Vulnerabilities published for uwsgi in the last 30 days: 0. Listed in the KEV catalogue: 0.
Vulnerabilities: 2
uWSGI before 2.0.17 mishandles a DOCUMENT_ROOT check during use of the --php-docroot option, allowing directory traversal.
The uwsgi_expand_path function in core/utils.c in Unbit uWSGI through 2.0.15 has a stack-based buffer overflow via a large directory length.
Check your installed stack and versions against the current vulnerability feeds.