p PatchFirst

CVE-2019-10064

CVE-2019-10064

This page contains facts from public vulnerability sources. Check the original advisory before updating.

hostapd before 2.6, in EAP mode, makes calls to the rand() and random() standard library functions without any preceding srand() or srandom() call, which results in inappropriate use of deterministic values. This was fixed in conjunction with CVE-2016-10743.

CVSS 7.5 · High · EPSS 3.8% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • wpa Debian:12

    Affected ranges
    • ECOSYSTEM: < 2:2.6-7

    Update to 2:2.6-7

  • wpa Debian:13

    Affected ranges
    • ECOSYSTEM: < 2:2.6-7

    Update to 2:2.6-7

  • wpa Debian:14

    Affected ranges
    • ECOSYSTEM: < 2:2.6-7

    Update to 2:2.6-7

  • wpa Ubuntu:Pro:14.04:LTS

    Versions
    • 1.0-3ubuntu2
    • 1.0-3ubuntu3
    • 1.0-3ubuntu4
    • 2.1-0ubuntu1
    • 2.1-0ubuntu1.1
    • 2.1-0ubuntu1.2
    • 2.1-0ubuntu1.3
    • 2.1-0ubuntu1.4
    • 2.1-0ubuntu1.5
    • 2.1-0ubuntu1.6
    • 2.1-0ubuntu1.7
    • 2.1-0ubuntu1.7+esm1
    • 2.1-0ubuntu1.7+esm2
    • 2.1-0ubuntu1.7+esm3
    • 2.1-0ubuntu1.7+esm4
    • 2.1-0ubuntu1.7+esm5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • wpa Ubuntu:16.04:LTS

    Versions
    • 2.4-0ubuntu3
    • 2.4-0ubuntu4
    • 2.4-0ubuntu5
    • 2.4-0ubuntu6
    • 2.4-0ubuntu6.2
    • 2.4-0ubuntu6.3
    • 2.4-0ubuntu6.4
    • 2.4-0ubuntu6.5
    • 2.4-0ubuntu6.6
    • 2.4-0ubuntu6.7
    • 2.4-0ubuntu6.8
    • 2.4-0ubuntu6.8+esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →