p PatchFirst

PatchFirst · Latest vulnerabilities

wpa vulnerabilities

Vulnerability published for wpa in the last 30 days: 1. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 12

  1. CVE-2026-49878

    High · CVSS 7.2EPSS 0.29%No fix published

    CVE-2026-49878

    In wpas_handle_robust_av_scs_recv_action of robust_av.c, there is a possible out-of-bounds write due to a logic error in the code. This could lead to remote code execution with System execution privileges needed. User interaction is not needed for exploitation.

    Published Updated
  2. CVE-2026-78807

    High · CVSS 7.1EPSS 0.08%No fix published

    CVE-2026-78807

    An issue in wpa_supplicant all versions before v.2.12 allows a local attacker to bypass proper network context and AKMP matching for PMKSA caching via missing validation in the driver based PMKSA selection path in wpa.c

    Published Updated
  3. CVE-2023-52160

    Medium · CVSS 6.5EPSS 1.18%No fix published

    CVE-2023-52160

    The implementation of PEAP in wpa_supplicant through 2.10 allows authentication bypass. For a successful attack, wpa_supplicant must be configured to not verify the network's TLS certificate during Phase 1 authentication, and an eap_peap_decrypt vulnerability can then be abused to skip Phase 2 authentication. The attack vector is sending an EAP-TLV Success packet instead of starting Phase 2. This allows an adversary to impersonate Enterprise Wi-Fi networks.

    Published Updated
  4. CVE-2021-27803

    High · CVSS 7.5EPSS 1.23%Fix available

    CVE-2021-27803

    A vulnerability was discovered in how p2p/p2p_pd.c in wpa_supplicant before 2.10 processes P2P (Wi-Fi Direct) provision discovery requests. It could result in denial of service or other impact (potentially execution of arbitrary code), for an attacker within radio range.

    • Update to 2.1-0ubuntu1.7+esm4
    Published Updated
  5. CVE-2021-0326

    High · CVSS 7.5EPSS 4.93%Fix available

    CVE-2021-0326

    In p2p_copy_client_info of p2p.c, there is a possible out of bounds write due to a missing bounds check. This could lead to remote code execution if the target device is performing a Wi-Fi Direct search, with no additional execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android-10 Android-11 Android-8.1 Android-9Android ID: A-172937525

    • Update to 2.1-0ubuntu1.7+esm3
    Published Updated
  6. CVE-2019-5062

    High · CVSS 7.4EPSS 0.57%No fix published

    CVE-2019-5062

    An exploitable denial-of-service vulnerability exists in the 802.11w security state handling for hostapd 2.6 connected clients with valid 802.11w sessions. By simulating an incomplete new association, an attacker can trigger a deauthentication against stations using 802.11w, resulting in a denial of service.

    Published Updated
  7. CVE-2019-5061

    High · CVSS 7.4EPSS 0.92%No fix published

    CVE-2019-5061

    An exploitable denial-of-service vulnerability exists in the hostapd 2.6, where an attacker could trigger AP to send IAPP location updates for stations, before the required authentication process has completed. This could lead to different denial of service scenarios, either by causing CAM table attacks, or by leading to traffic flapping if faking already existing clients in other nearby Aps of the same wireless infrastructure. An attacker can forge Authentication and Association Request packets to trigger this vulnerability.

    Published Updated
  8. CVE-2019-16275

    Medium · CVSS 6.5EPSS 1.21%Fix available

    CVE-2019-16275

    hostapd before 2.10 and wpa_supplicant before 2.10 allow an incorrect indication of disconnection in certain situations because source address validation is mishandled. This is a denial of service that should have been prevented by PMF (aka management frame protection). The attacker must send a crafted 802.11 frame from a location that is within the 802.11 communications range.

    • Update to 2.1-0ubuntu1.7+esm2
    Published Updated
  9. CVE-2019-2053

    Medium · CVSS 5.5EPSS 0.17%No fix published

    CVE-2019-2053

    In wnm_parse_neighbor_report_elem of wnm_sta.c, there is a possible out-of-bounds read due to missing bounds check. This could lead to local information disclosure with no additional execution privileges needed. User interaction is not needed for exploitation. Product: Android Versions: Android-7.0 Android-7.1.1 Android-7.1.2 Android-8.0 Android-8.1 Android-9 Android ID: A-122074159

    Published Updated
  10. CVE-2019-11555

    Medium · CVSS 5.9EPSS 3.25%Fix available

    CVE-2019-11555

    The EAP-pwd implementation in hostapd (EAP server) before 2.8 and wpa_supplicant (EAP peer) before 2.8 does not validate fragmentation reassembly state properly for a case where an unexpected fragment could be received. This could result in process termination due to a NULL pointer dereference (denial of service). This affects eap_server/eap_server_pwd.c and eap_peer/eap_pwd.c.

    • Update to 2.1-0ubuntu1.7+esm1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →