p PatchFirst

CVE-2019-1010083

CVE-2019-1010083

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The Pallets Project Flask before 1.0 is affected by: unexpected memory usage. The impact is: denial of service. The attack vector is: crafted encoded JSON data. The fixed version is: 1. NOTE: this may overlap CVE-2018-1000656.

CVSS 8.7 · High · EPSS 1.8% · Fix available

Published
Updated

Stack: system · python

Affected products and versions

  • flask

    Versions
    • ≤ 1.0 [fixed: 1]: Affected

    No fix published

  • flask Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.0.2-1

    Update to 1.0.2-1

  • flask Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.0.2-1

    Update to 1.0.2-1

  • flask Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.0.2-1

    Update to 1.0.2-1

  • flask PyPI

    Versions
    • 0.1
    • 0.10
    • 0.10.1
    • 0.11
    • 0.11.1
    • 0.12
    • 0.12.1
    • 0.12.2
    • 0.12.3
    • 0.12.4
    • 0.12.5
    • 0.2
    • 0.3
    • 0.3.1
    • 0.4
    • 0.5
    • 0.5.1
    • 0.5.2
    • 0.6
    • 0.6.1
    • 0.7
    • 0.7.1
    • 0.7.2
    • 0.8
    • 0.8.1
    • 0.9
    Affected ranges
    • ECOSYSTEM: < 1.0

    Update to 1.0

Original sources

Check your server →