p PatchFirst

PatchFirst · Latest vulnerabilities

flask vulnerabilities

Vulnerabilities published for flask in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 4

  1. CVE-2026-27205

    Low · CVSS 2.3EPSS 0.4%No fix published

    Flask session does not add `Vary: Cookie` header when accessed in some ways

    Flask is a web server gateway interface (WSGI) web application framework. In versions 3.1.2 and below, when the session object is accessed, Flask should set the Vary: Cookie header., resulting in a Use of Cache Containing Sensitive Information vulnerability. The logic instructs caches not to cache the response, as it may contain information specific to a logged in user. This is handled in most cases, but some forms of access such as the Python in operator were overlooked. The severity and risk depend on the application being hosted behind a caching proxy that doesn't ignore responses with cookies, not setting a Cache-Control header to mark pa

    Published Updated
  2. CVE-2023-30861

    High · CVSS 7.5EPSS 1.25%Public exploitFix available

    Flask vulnerable to possible disclosure of permanent session cookie due to missing Vary: Cookie header

    Flask is a lightweight WSGI web application framework. When all of the following conditions are met, a response containing data intended for one client may be cached and subsequently sent by the proxy to other clients. If the proxy also caches `Set-Cookie` headers, it may send one client's `session` cookie to other clients. The severity depends on the application's use of the session and the proxy's behavior regarding cookies. The risk depends on all these conditions being met. 1. The application must be hosted behind a caching proxy that does not strip cookies or ignore responses with cookies. 2. The application sets `session.permanent = Tr

    • Update to 2.2.2-3
    Published Updated
  3. CVE-2019-1010083

    High · CVSS 8.7EPSS 1.83%Fix available

    CVE-2019-1010083

    The Pallets Project Flask before 1.0 is affected by: unexpected memory usage. The impact is: denial of service. The attack vector is: crafted encoded JSON data. The fixed version is: 1. NOTE: this may overlap CVE-2018-1000656.

    • Update to 1.0.2-1
    Published Updated
  4. CVE-2018-1000656

    High · CVSS 8.7EPSS 3.85%Fix available

    CVE-2018-1000656

    The Pallets Project flask version Before 0.12.3 contains a CWE-20: Improper Input Validation vulnerability in flask that can result in Large amount of memory usage possibly leading to denial of service. This attack appear to be exploitable via Attacker provides JSON data in incorrect encoding. This vulnerability appears to have been fixed in 0.12.3. NOTE: this may overlap CVE-2019-1010083.

    • Update to 1.0.2-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →