CVE-2019-10216
CVE-2019-10216
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In ghostscript before version 9.50, the .buildfont1 procedure did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions. An attacker could abuse this flaw by creating a specially crafted PostScript file that could escalate privileges and access files outside of restricted areas.
CVSS 7.3 · High · EPSS 2.3% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
ghostscript
- Versions
- before 9.50: Affected
No fix published
ghostscript Debian:12
- Affected ranges
- ECOSYSTEM: < 9.27~dfsg-3.1
Update to 9.27~dfsg-3.1
ghostscript Debian:13
- Affected ranges
- ECOSYSTEM: < 9.27~dfsg-3.1
Update to 9.27~dfsg-3.1
ghostscript Debian:14
- Affected ranges
- ECOSYSTEM: < 9.27~dfsg-3.1
Update to 9.27~dfsg-3.1
ghostscript Ubuntu:16.04:LTS
- Versions
- 9.16~dfsg~0-0ubuntu3
- 9.16~dfsg~0-0ubuntu4
- 9.18~dfsg~0-0ubuntu1
- 9.18~dfsg~0-0ubuntu2
- 9.18~dfsg~0-0ubuntu2.2
- 9.18~dfsg~0-0ubuntu2.3
- 9.18~dfsg~0-0ubuntu2.4
- 9.18~dfsg~0-0ubuntu2.6
- 9.18~dfsg~0-0ubuntu2.7
- 9.18~dfsg~0-0ubuntu2.8
- 9.18~dfsg~0-0ubuntu2.9
- 9.25~dfsg+1-0ubuntu0.16.04.1
- 9.25~dfsg+1-0ubuntu0.16.04.2
- 9.25~dfsg+1-0ubuntu0.16.04.3
- 9.26~dfsg+0-0ubuntu0.16.04.1
- 9.26~dfsg+0-0ubuntu0.16.04.3
- 9.26~dfsg+0-0ubuntu0.16.04.4
- 9.26~dfsg+0-0ubuntu0.16.04.5
- 9.26~dfsg+0-0ubuntu0.16.04.6
- 9.26~dfsg+0-0ubuntu0.16.04.7
- 9.26~dfsg+0-0ubuntu0.16.04.8
- 9.26~dfsg+0-0ubuntu0.16.04.9
- Affected ranges
- ECOSYSTEM: < 9.26~dfsg+0-0ubuntu0.16.04.10
Update to 9.26~dfsg+0-0ubuntu0.16.04.10
ghostscript Ubuntu:18.04:LTS
- Versions
- 9.21~dfsg+1-0ubuntu3
- 9.22~dfsg+1-0ubuntu1
- 9.22~dfsg+1-0ubuntu1.1
- 9.22~dfsg+1-0ubuntu1.2
- 9.25~dfsg+1-0ubuntu0.18.04.1
- 9.25~dfsg+1-0ubuntu0.18.04.2
- 9.26~dfsg+0-0ubuntu0.18.04.1
- 9.26~dfsg+0-0ubuntu0.18.04.3
- 9.26~dfsg+0-0ubuntu0.18.04.4
- 9.26~dfsg+0-0ubuntu0.18.04.5
- 9.26~dfsg+0-0ubuntu0.18.04.6
- 9.26~dfsg+0-0ubuntu0.18.04.7
- 9.26~dfsg+0-0ubuntu0.18.04.8
- 9.26~dfsg+0-0ubuntu0.18.04.9
- Affected ranges
- ECOSYSTEM: < 9.26~dfsg+0-0ubuntu0.18.04.10
Update to 9.26~dfsg+0-0ubuntu0.18.04.10