p PatchFirst

CVE-2019-12293

CVE-2019-12293

This page contains facts from public vulnerability sources. Check the original advisory before updating.

In Poppler through 0.76.1, there is a heap-based buffer over-read in JPXStream::init in JPEG2000Stream.cc via data with inconsistent heights or widths.

CVSS 8.8 · High · EPSS 2.1% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • poppler Debian:12

    Affected ranges
    • ECOSYSTEM: < 0.71.0-5

    Update to 0.71.0-5

  • poppler Debian:13

    Affected ranges
    • ECOSYSTEM: < 0.71.0-5

    Update to 0.71.0-5

  • poppler Debian:14

    Affected ranges
    • ECOSYSTEM: < 0.71.0-5

    Update to 0.71.0-5

  • poppler Ubuntu:16.04:LTS

    Versions
    • 0.33.0-0ubuntu3
    • 0.37.0-0ubuntu1
    • 0.38.0-0ubuntu1
    • 0.41.0-0ubuntu1
    • 0.41.0-0ubuntu1.1
    • 0.41.0-0ubuntu1.2
    • 0.41.0-0ubuntu1.3
    • 0.41.0-0ubuntu1.4
    • 0.41.0-0ubuntu1.5
    • 0.41.0-0ubuntu1.6
    • 0.41.0-0ubuntu1.7
    • 0.41.0-0ubuntu1.8
    • 0.41.0-0ubuntu1.9
    • 0.41.0-0ubuntu1.10
    • 0.41.0-0ubuntu1.11
    • 0.41.0-0ubuntu1.12
    • 0.41.0-0ubuntu1.13
    Affected ranges
    • ECOSYSTEM: < 0.41.0-0ubuntu1.14

    Update to 0.41.0-0ubuntu1.14

  • poppler Ubuntu:18.04:LTS

    Versions
    • 0.57.0-2ubuntu4
    • 0.57.0-2ubuntu5
    • 0.62.0-1ubuntu1
    • 0.62.0-2ubuntu1
    • 0.62.0-2ubuntu2
    • 0.62.0-2ubuntu2.1
    • 0.62.0-2ubuntu2.2
    • 0.62.0-2ubuntu2.4
    • 0.62.0-2ubuntu2.5
    • 0.62.0-2ubuntu2.6
    • 0.62.0-2ubuntu2.7
    • 0.62.0-2ubuntu2.8
    Affected ranges
    • ECOSYSTEM: < 0.62.0-2ubuntu2.9

    Update to 0.62.0-2ubuntu2.9

Original sources

Check your server →